missing mistral dashboard config file

Bug #1649669 reported by CSJ on 2016-12-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mistral
Undecided
Sharat Sharma
kolla
Undecided
Unassigned

Bug Description

_50_mistral.py.example doesn't exist in current mistral-dashboard-master.tar.gz

I also comment below this commit https://github.com/openstack/kolla/commit/9a3192f570ef2d18018fce875164967c436a119b

Changed in kolla:
assignee: nobody → Mauricio Lima (mliima) (mauricio-lima)
status: New → Invalid
assignee: Mauricio Lima (mliima) (mauricio-lima) → nobody

I checked and _50_mistral.py.example exist in current mistral-dashboard-master.tar.gz

CSJ (changsijay) wrote :

can I reopen this issue?

Actually the file not exist is because the wrong folder name not filename,
should be "mistral-dashboard"?

CSJ (changsijay) wrote :

sorry, maybe about the folder level, not sure how to get into horizon container now.
Anyway, if enabled mistral, horizon will keep restart caused the missing file...

CSJ (changsijay) wrote :

INFO:__main__:Writing out command to execute
cp: cannot stat '/var/lib/kolla/venv/lib/python2.7/site-packages/mistral_dashboard/_50_mistral.py.example': No such file or directory

Jeffrey Zhang (jeffrey4l) wrote :

i pushed patch to fix the issue in mistral-dashboard. https://review.openstack.org/413908

Changed in kolla:
status: Invalid → Confirmed
milestone: none → ocata-3
Changed in mistral:
assignee: nobody → Sharat Sharma (sharat-sharma)
Changed in mistral:
status: New → In Progress
Changed in mistral:
milestone: none → ocata-3
Changed in kolla:
importance: Undecided → Medium

Reviewed: https://review.openstack.org/413908
Committed: https://git.openstack.org/cgit/openstack/mistral-dashboard/commit/?id=b1c1627940dd48f8029ba3d439a564c20d934568
Submitter: Jenkins
Branch: master

commit b1c1627940dd48f8029ba3d439a564c20d934568
Author: Jeffrey Zhang <email address hidden>
Date: Thu Dec 22 13:00:46 2016 +0800

    Move _50_mistral.py file into enabled folder

    if not, this file is not included when installing from pypi.

    Closes-Bug: #1649669
    Change-Id: Ie1415ea66ed6608ecff622c42e3a433be23bbdfe
    Co-Authored-By: Sharat Sharma<email address hidden>

Changed in mistral:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/413953
Committed: https://git.openstack.org/cgit/openstack/mistral/commit/?id=462cbf1366bc9f8f29769d3fbc49c8c84bf60511
Submitter: Jenkins
Branch: master

commit 462cbf1366bc9f8f29769d3fbc49c8c84bf60511
Author: Jeffrey Zhang <email address hidden>
Date: Thu Dec 22 15:53:04 2016 +0800

    Copy _50_mistral.py file from enabled folder

    Change-Id: I6b355a9f4ee616b081e9a715cacd3a062e1f743c
    Closes-Bug: #1649669
    Depends-On: Ie1415ea66ed6608ecff622c42e3a433be23bbdfe

This issue was fixed in the openstack/mistral 4.0.0.0b3 development milestone.

This issue was fixed in the openstack/mistral-dashboard 4.0.0.0b3 development milestone.

This is an automated cleanup. This bug report has been closed because it
is older than 18 months and there is no open code change to fix this.
After this time it is unlikely that the circumstances which lead to
the observed issue can be reproduced.

If you can reproduce the bug, please:
* reopen the bug report (set to status "New")
* AND add the detailed steps to reproduce the issue (if applicable)
* AND leave a comment "CONFIRMED FOR: <RELEASE_NAME>"
  Only still supported release names are valid (OCATA, PIKE, QUEENS, ROCKY, ROCKY).
  Valid example: CONFIRMED FOR: OCATA

Changed in kolla:
importance: Medium → Undecided
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers