missing heka-ceilometer.toml in ceilometer_compute container

Bug #1642665 reported by Javier Castillo on 2016-11-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
Undecided
Unassigned
Newton
Undecided
Mauricio Lima (mliima)
kolla-ansible
Undecided
Unassigned

Bug Description

ceilometer_compute container is not sending logs to heka because no heka-ceilometer.toml is created:

(heka)[heka@compute01 /]$ ls -l /etc/heka/
total 40
drwxr-xr-x 2 heka heka 4096 Nov 17 10:06 conf.d
-rw------- 1 heka heka 563 Nov 17 13:09 heka-elasticsearch.toml
-rw------- 1 heka heka 655 Nov 17 13:09 heka-global.toml
-rw------- 1 heka heka 295 Nov 17 13:09 heka-haproxy.toml
-rw------- 1 heka heka 503 Nov 17 13:09 heka-horizon.toml
-rw------- 1 heka heka 310 Nov 17 13:09 heka-keepalived.toml
-rw------- 1 heka heka 545 Nov 17 13:09 heka-keystone.toml
-rw------- 1 heka heka 310 Nov 17 13:09 heka-mariadb.toml
-rw------- 1 heka heka 449 Nov 17 13:09 heka-openstack.toml
-rw------- 1 heka heka 499 Nov 17 13:09 heka-rabbitmq.toml

Changed in kolla-ansible:
milestone: none → ocata-2
Liyingjun (liyingjun) wrote :
Changed in kolla-ansible:
status: New → Invalid
Eduardo Gonzalez (egonzalez90) wrote :

Ceilometer is executed with wsgi, logs should be retrieved with apache syntax. A new toml is needed.
https://github.com/openstack/kolla-ansible/blob/master/ansible/roles/ceilometer/templates/wsgi-ceilometer-api.conf.j2

Changed in kolla-ansible:
status: Invalid → Triaged

Change abandoned by Javier Castillo Alcíbar (<email address hidden>) on branch: master
Review: https://review.openstack.org/399134
Reason: Changed abandoned in favour of https://review.openstack.org/400168

Javier Castillo (javcasalc) wrote :

Hi

I've uploaded a new change: https://review.openstack.org/400168

But my change focus on defining a custom heka-ceilometer.toml file instead of defining a ceilometer patter into generic heka-openstack.toml

Reviewed: https://review.openstack.org/400168
Committed: https://git.openstack.org/cgit/openstack/kolla-ansible/commit/?id=31eac33ddb96d92bd316d15afd6b5ae5fc63c4fc
Submitter: Jenkins
Branch: master

commit 31eac33ddb96d92bd316d15afd6b5ae5fc63c4fc
Author: Javier Castillo Alcíbar <email address hidden>
Date: Mon Nov 21 11:32:03 2016 +0100

    Fix ceilometer not sending logs to heka

    ceilometer is not sending logs to heka because no heka-ceilometer.toml is created.
    Updated templates files.

    Change-Id: I69f3d93377c6c51d22f37ed120800f7489f5a8a0
    Closes-Bug: #1642665

Changed in kolla-ansible:
status: Triaged → Fix Released
Javier Castillo (javcasalc) wrote :

I have added a new heka-ceilometer.toml template in order to manage both generators: apache and openstack.

This issue was fixed in the openstack/kolla-ansible 4.0.0.0b2 development milestone.

Change abandoned by Javier Castillo Alcíbar (<email address hidden>) on branch: master
Review: https://review.openstack.org/400716
Reason: abandon requested

Change abandoned by Mauricio Lima (<email address hidden>) on branch: stable/newton
Review: https://review.openstack.org/411434
Reason: Cherry Pick https://review.openstack.org/#/c/411794/

Reviewed: https://review.openstack.org/411794
Committed: https://git.openstack.org/cgit/openstack/kolla/commit/?id=98845fd020630545e4c94816658020031867a600
Submitter: Jenkins
Branch: stable/newton

commit 98845fd020630545e4c94816658020031867a600
Author: Javier Castillo Alcíbar <email address hidden>
Date: Mon Nov 21 11:32:03 2016 +0100

    Fix ceilometer not sending logs to heka

    ceilometer is not sending logs to heka because no heka-ceilometer.toml is created.
    Updated templates files.

    Change-Id: I69f3d93377c6c51d22f37ed120800f7489f5a8a0
    Closes-Bug: #1642665
    (cherry picked from commit 31eac33ddb96d92bd316d15afd6b5ae5fc63c4fc)

This issue was fixed in the openstack/kolla 3.0.3 release.

This is an automated cleanup. This bug report has been closed because it
is older than 18 months and there is no open code change to fix this.
After this time it is unlikely that the circumstances which lead to
the observed issue can be reproduced.

If you can reproduce the bug, please:
* reopen the bug report (set to status "New")
* AND add the detailed steps to reproduce the issue (if applicable)
* AND leave a comment "CONFIRMED FOR: <RELEASE_NAME>"
  Only still supported release names are valid (OCATA, PIKE, QUEENS, ROCKY, ROCKY).
  Valid example: CONFIRMED FOR: OCATA

Changed in kolla:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers