gnocchi deploy fails on centos binary

Bug #1634148 reported by bjolo on 2016-10-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
High
Unassigned
Newton
High
Unassigned

Bug Description

env: kolla stable/newton; centos binary

gnocchi fails to deploy on centos binary. (works on centos source)

deploy -vvv log | grep gnocchi
http://paste.openstack.org/show/585957/

George Zhao (georgezhao) wrote :

Modify kolla/docker/gnocchi/gnocchi-api/extend_start.sh

sudo -H -i -u gnocchi gnocchi-upgrade --create-legacy-resource-types --logfile /var/log/kolla/gnocchi/gnocchi-upgrade.log

to

sudo -H -u gnocchi gnocchi-upgrade --create-legacy-resource-types --logfile /var/log/kolla/gnocchi/gnocchi-upgrade.log

User gnocchi doesn't have a shell, sudo -i will give an error.

bjolo (bjorn-lofdahl) wrote :

George,

Are you submitting a PS for this or where do we stand?

b

Jeffrey Zhang (jeffrey4l) wrote :

will you two guys push a fix, which is very easy. :)

Changed in kolla:
milestone: none → ocata-1
status: New → Confirmed
importance: Undecided → High

Reviewed: https://review.openstack.org/392465
Committed: https://git.openstack.org/cgit/openstack/kolla/commit/?id=6ca1c68b201af5365fd2123bdcd59eb72b476b41
Submitter: Jenkins
Branch: master

commit 6ca1c68b201af5365fd2123bdcd59eb72b476b41
Author: bjorn lofdahl <email address hidden>
Date: Wed Nov 2 09:37:37 2016 +0100

    Fix gnocchi deploy

    Gnocchi deploy fails due to sudo -i flag

    Change-Id: Id1e2af274a3aee43dfecf02f979a9584dd2cffa8
    Closes-Bug: #1634148

Changed in kolla:
status: Confirmed → Fix Released

Reviewed: https://review.openstack.org/392723
Committed: https://git.openstack.org/cgit/openstack/kolla/commit/?id=dc058e7b81ab0f011744ba44ed519cb4832e4fa9
Submitter: Jenkins
Branch: stable/newton

commit dc058e7b81ab0f011744ba44ed519cb4832e4fa9
Author: bjorn lofdahl <email address hidden>
Date: Wed Nov 2 09:37:37 2016 +0100

    Fix gnocchi deploy

    Gnocchi deploy fails due to sudo -i flag

    Change-Id: Id1e2af274a3aee43dfecf02f979a9584dd2cffa8
    Closes-Bug: #1634148
    (cherry picked from commit 6ca1c68b201af5365fd2123bdcd59eb72b476b41)

This issue was fixed in the openstack/kolla 4.0.0.0b1 development milestone.

This issue was fixed in the openstack/kolla 3.0.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers