Docker Version Check fails in error

Bug #1602712 reported by Steven Pisarski on 2016-07-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kolla
Wishlist
Unassigned

Bug Description

I have installed the latest docker version 1.11.2 and the prechecks task on kolla-ansible is failing even though the minimum version is 1.10. Please see the ansible logs below:

TASK [prechecks : Checking Docker version] *************************************
fatal: [node5]: FAILED! => {"changed": false, "cmd": ["docker", "version"], "delta": "0:00:00.013148", "end": "2016-07-13 08:19:34.490367", "failed": true, "failed_when_result": true, "rc": 1, "start": "2016-07-13 08:19:34.477219", "stderr": "Cannot connect to the Docker daemon. Is the docker daemon running on this host?", "stdout": "Client:\n Version: 1.11.2\n API version: 1.23\n Go version: go1.5.4\n Git commit: b9f10c9\n Built: Wed Jun 1 22:00:43 2016\n OS/Arch: linux/amd64", "stdout_lines": ["Client:", " Version: 1.11.2", " API version: 1.23", " Go version: go1.5.4", " Git commit: b9f10c9", " Built: Wed Jun 1 22:00:43 2016", " OS/Arch: linux/amd64"], "warnings": []}
fatal: [node1]: FAILED! => {"changed": false, "cmd": ["docker", "version"], "delta": "0:00:00.018061", "end": "2016-07-13 08:19:34.515649", "failed": true, "failed_when_result": true, "rc": 1, "start": "2016-07-13 08:19:34.497588", "stderr": "Cannot connect to the Docker daemon. Is the docker daemon running on this host?", "stdout": "Client:\n Version: 1.11.2\n API version: 1.23\n Go version: go1.5.4\n Git commit: b9f10c9\n Built: Wed Jun 1 22:00:43 2016\n OS/Arch: linux/amd64", "stdout_lines": ["Client:", " Version: 1.11.2", " API version: 1.23", " Go version: go1.5.4", " Git commit: b9f10c9", " Built: Wed Jun 1 22:00:43 2016", " OS/Arch: linux/amd64"], "warnings": []}
fatal: [node4]: FAILED! => {"changed": false, "cmd": ["docker", "version"], "delta": "0:00:00.012889", "end": "2016-07-13 08:19:34.516979", "failed": true, "failed_when_result": true, "rc": 1, "start": "2016-07-13 08:19:34.504090", "stderr": "Cannot connect to the Docker daemon. Is the docker daemon running on this host?", "stdout": "Client:\n Version: 1.11.2\n API version: 1.23\n Go version: go1.5.4\n Git commit: b9f10c9\n Built: Wed Jun 1 22:00:43 2016\n OS/Arch: linux/amd64", "stdout_lines": ["Client:", " Version: 1.11.2", " API version: 1.23", " Go version: go1.5.4", " Git commit: b9f10c9", " Built: Wed Jun 1 22:00:43 2016", " OS/Arch: linux/amd64"], "warnings": []}
fatal: [node2]: FAILED! => {"changed": false, "cmd": ["docker", "version"], "delta": "0:00:00.012024", "end": "2016-07-13 08:19:34.535055", "failed": true, "failed_when_result": true, "rc": 1, "start": "2016-07-13 08:19:34.523031", "stderr": "Cannot connect to the Docker daemon. Is the docker daemon running on this host?", "stdout": "Client:\n Version: 1.11.2\n API version: 1.23\n Go version: go1.5.4\n Git commit: b9f10c9\n Built: Wed Jun 1 22:00:43 2016\n OS/Arch: linux/amd64", "stdout_lines": ["Client:", " Version: 1.11.2", " API version: 1.23", " Go version: go1.5.4", " Git commit: b9f10c9", " Built: Wed Jun 1 22:00:43 2016", " OS/Arch: linux/amd64"], "warnings": []}
fatal: [node3]: FAILED! => {"changed": false, "cmd": ["docker", "version"], "delta": "0:00:00.011852", "end": "2016-07-13 08:19:34.538148", "failed": true, "failed_when_result": true, "rc": 1, "start": "2016-07-13 08:19:34.526296", "stderr": "Cannot connect to the Docker daemon. Is the docker daemon running on this host?", "stdout": "Client:\n Version: 1.11.2\n API version: 1.23\n Go version: go1.5.4\n Git commit: b9f10c9\n Built: Wed Jun 1 22:00:43 2016\n OS/Arch: linux/amd64", "stdout_lines": ["Client:", " Version: 1.11.2", " API version: 1.23", " Go version: go1.5.4", " Git commit: b9f10c9", " Built: Wed Jun 1 22:00:43 2016", " OS/Arch: linux/amd64"], "warnings": []}

Brandon B. Jozsa (bjozsa) wrote :

Could you attempt the following and report back?

First, make sure that docker permissions aren't the issue. You can fix them later for better security, but start with the following:
$ sudo usermod -aG docker

Then if that doesn't work, you can attempt to modify the following:
$ sudo vi /opt/kolla/ansible/roles/prechecks/vars/main.yml

You'll see max/min settings. Adjust for your Docker version.

Reinstall like the following:
$ sudo pip install ./opt/kolla/ --upgrade

Does that get you past this hurdle?

Brandon B. Jozsa (bjozsa) wrote :

sorry, wish we could edit on this tool. I meant to say the following (which is pretty obvious, but still):

$ sudo usermod -aG docker {{your_username}

Changed in kolla:
status: New → Incomplete
Steven Pisarski (spisarski) wrote :

Sorry for the delay in my reply as had PTO and other pressing issues. Adding the user to the docker group did the trick!

zhubingbing (zhubingbing) wrote :

spisarski, glad you solved the problem, so we close this bug

Changed in kolla:
milestone: none → newton-rc2
status: Incomplete → Fix Released
Changed in kolla:
status: Fix Released → Invalid
Duong Ha-Quang (duonghq) wrote :

Kolla's report is very confusing on Docker permission-related error. We should fix that in future, so I move it to o-1, need more opinion. Maybe we need make more general bug report.

I tried to fix it at [1] but many edge cases come out.

[1] https://review.openstack.org/#/c/358432/

Changed in kolla:
milestone: newton-rc2 → ocata-1
status: Invalid → Opinion
Steven Dake (sdake) wrote :

I changed this to confirmed since the root cause was determined (user error) but the code could do something a little more intuitive then spit out a huge backtrace. At least we know how to guide people that run into this problem. This is actually the first time I've heard this reported...

Changed in kolla:
status: Opinion → Confirmed
importance: Undecided → Low
Changed in kolla:
milestone: ocata-1 → ocata-2
Changed in kolla:
importance: Low → Wishlist
Changed in kolla:
milestone: ocata-2 → ocata-3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers