Tech-Debt: Namespace the Docker volumes

Bug #1547533 reported by Éric Lemoine on 2016-02-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
Medium
Steven Dake

Bug Description

Currently the Docker named volumes created by Kolla don't have a namespace/prefix.

For example, on my AIO installation:

    [root@operator kolla]# docker volume ls
    DRIVER VOLUME NAME
    local heka
    local nova_compute
    local nova_libvirt
    local kolla_logs
    local rsyslog_socket
    local haproxy_socket
    local mariadb
    local rabbitmq
    local rsyslog
    local heka_socket

In https://review.openstack.org/#/c/275841/20/ansible/roles/common/tasks/start.yml@26 Steve suggested that we namespace our named volumes: kolla_heka, kolla_mariadb, etc.

Steven Dake (sdake) wrote :

Making critical since this would have repercussions when we were to namespace our named volumes down the road. Might as well take care of it now.

Changed in kolla:
importance: Undecided → Critical
status: New → Confirmed
milestone: none → mitaka-3
Steven Dake (sdake) wrote :

[07:14:35] <sdake> actually I'm not sure namespacing makes sense
[07:14:40] <sdake> since we expect dedicated gear
[07:14:47] <sdake> and the rest of our services are nto namespaced

Changed in kolla:
importance: Critical → Medium
Steven Dake (sdake) wrote :

Changed to medium priority.

Éric Lemoine (elemoine) wrote :

> actually I'm not sure namespacing makes sense since we expect dedicated gear and the rest of our services are nto namespaced

In that case I think we should be consistent and rename the volume "kolla_logs" to "logs". During the review process Sam Yaple suggested that I rename the logs volume from "logs" to "kolla_logs" (or something else) to avoid volume name conflicts. I'd say let's be consistent and use the kolla_ prefix for all the Docker volumes created by Kolla or for none. My preference is to not use the kolla_ prefix and effectively rename the volume "kolla_logs" to "logs".

Éric Lemoine (elemoine) wrote :

If people thing "logs" is too generic as a name another option is to rename "kolla_logs" to "service_logs".

Changed in kolla:
assignee: nobody → Rahul U Nair (rahulunair)
assignee: Rahul U Nair (rahulunair) → nobody
Steven Dake (sdake) wrote :

I am pretty certain we don't need namespacing of the volumes since the nodes used in a Kolla deployment are dedicated except in development environments. As such, closing as wontfix.

Changed in kolla:
assignee: nobody → Steven Dake (sdake)
status: Confirmed → Invalid
status: Invalid → Won't Fix
Éric Lemoine (elemoine) wrote :

Why are we making an exception for the "kolla_logs" volume? I am +1 on renaming kolla_logs to logs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers