Deployment with existing database server

Bug #1530416 reported by Lingfeng Xiong on 2016-01-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
Wishlist
Unassigned

Bug Description

It is common to deploy a openstack installation with existing database server. But current Kolla seems only support deployment against the built-in MariaDB. Is there any plans to support external database/message queue deployment?

Steven Dake (sdake) wrote :

I am pretty sure this can be done today, but requires documentation to explain how to do the job.

Changed in kolla:
status: New → Triaged
importance: Undecided → Wishlist
milestone: none → mitaka-3
Lingfeng Xiong (xionglingfeng) wrote :

Steven, I tried to modify inventory files to remove the deployment of mariadb, but the deployment stalled at waiting for virtual IP to appear.
Then I modify ansible script to use other ports (ssh) instead of mariadb port (3306), but the deployment also failed because the database connection strings are not defined.
So I think it do requires some modifications on the current ansible scripts.

Steven Dake (sdake) wrote :

Lingfeng,

If you can propose a solution, we would take this in rc1.

Changed in kolla:
milestone: mitaka-3 → mitaka-rc1
Steven Dake (sdake) on 2016-03-17
Changed in kolla:
milestone: mitaka-rc1 → mitaka-rc2
Steven Dake (sdake) on 2016-03-22
Changed in kolla:
milestone: mitaka-rc2 → newton-1
Swapnil Kulkarni (coolsvap) wrote :

This is not updated since mitaka rc-1. Is there a plan to address this? Thanks

Swapnil

Changed in kolla:
milestone: newton-1 → newton-2
tags: added: retriage
Changed in kolla:
milestone: newton-2 → newton-3
Swapnil Kulkarni (coolsvap) wrote :

Marking it invalid since there is no update. Feel free to reconfirm. Thanks

Changed in kolla:
status: Triaged → Invalid
Steven Dake (sdake) on 2016-08-05
Changed in kolla:
status: Invalid → Confirmed
Changed in kolla:
milestone: newton-3 → newton-rc1
Changed in kolla:
milestone: newton-rc1 → newton-rc2
Changed in kolla:
milestone: newton-rc2 → ocata-1
Changed in kolla:
milestone: ocata-1 → ocata-2
Changed in kolla:
milestone: ocata-2 → ocata-3
Rob Ellison (robellison) wrote :

it would be good to have this for all common components
off the top of my head it's probably only these:
mariadb
rabbitmq
elasticsearch
ceph (already done)
haproxy

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers