Ansible is required in test-requirements.txt

Bug #1528093 reported by David Moreau Simard on 2015-12-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
Wishlist
Steven Dake

Bug Description

It looks like Kolla assumes Ansible is installed.

Ansible is not in requirements.txt, test-requirements.txt and not installed if missing in tools/kolla-ansible, leading to 'ansible-playbook' command not found if has not been installed prior to running.

I've witnessed this when running the tox deploy jobs for centos outside of the gate.

Steven Dake (sdake) on 2016-02-18
Changed in kolla:
importance: Undecided → Wishlist
status: New → Triaged
milestone: none → mitaka-3
Steven Dake (sdake) wrote :

Adding ansible to global requirements would be required to fix this. If we add a project to requirements.txt that isn't in global requirements, the requirements bot removes it later.

I believe it is policy of the global requirements project not to permit GPLV3 licensed software in the global requirements. I'm not clear there is anything we can do here, as the foundation is crystal clear that GPLV3 code is not permitted as a dependency.

The way we use Ansible is not as a dependency but as a piped process executed in a separate process. Essentially using GPLv3 software this way is compatible with the ASL2.0. This type of usage of GPLv3 is safe from licensing concerns from what I can tell on the legal mailer. IANAL - consult your legal counsel on this point or the foundation legal list.

Changed in kolla:
assignee: nobody → Steven Dake (sdake)
summary: - Kolla assumes ansible is installed ?
+ Ansible is required in test-requirements.txt
Steven Dake (sdake) wrote :

Marking wont-fix for reasons described in comment #1.

Changed in kolla:
status: Triaged → Invalid
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers