Config changes do not cause a container restart when using COPY_ALWAYS

Bug #1500858 reported by Paul Bourke on 2015-09-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
Critical
Steven Dake

Bug Description

When updating an augment file or template in Ansible, one would expect running containers to be restarted on deploy, when using the COPY_ALWAYS config strategy. Right now this doesn't seem to be the case - you have to find a way of manually restarting containers across hosts.

Is this intended behavior to lay the path for some form of upgrade strategy? If so it should probably be documented, if not, we need to update the tasks to restart containers on config change (when strategy == COPY_ALWAYS)

Sam Yaple (s8m) wrote :

The intended behavior for COPY_ALWAYS is to pull in a (possibly new) config everytime the container restarts. This does not have anything to do with a requirement to restart the container when configs have changed.

As initially discussed in the spec, COPY_ALWAYS was more intended for testing environments where you make a manual change on one node and restart the container for it to take effect.

As a whole, Kolla has not agreed on what the best way to pull in new configs should be. For example, we could trigger a handler based on a config change in the regular playbooks, or we could write a new playbook specific for just updating configs. Many options. Whatever is decided the same thing would happen for both COPY_ONCE and COPY_ALWAYS methods tasks and what not.

Steven Dake (sdake) on 2015-09-30
Changed in kolla:
status: New → Triaged
milestone: none → liberty-rc2
importance: Undecided → Wishlist
Steven Dake (sdake) on 2015-10-11
Changed in kolla:
milestone: liberty-rc2 → liberty-rc3
Sam Yaple (s8m) wrote :

I am not sure this is a bug guys. Or even a wishlist item. This is a conversation that needs to take place in a meeting.

Steven Dake (sdake) on 2015-10-12
Changed in kolla:
milestone: liberty-rc3 → mitaka-1
Sam Yaple (s8m) wrote :

Paul, I am going to mark this incomplete as I do not know what is expected to come from this bug.

This would be a blueprint or similar.

Please by all means update this and change the status back

Changed in kolla:
status: Triaged → Incomplete
Steven Dake (sdake) on 2016-01-06
Changed in kolla:
milestone: mitaka-1 → mitaka-2
Steven Dake (sdake) on 2016-01-22
Changed in kolla:
milestone: mitaka-2 → mitaka-3
Steven Dake (sdake) wrote :

We have resolved this problem with reconfigure. Marking as invalid. Thanks :)

Changed in kolla:
assignee: nobody → Steven Dake (sdake)
status: Incomplete → Invalid
importance: Wishlist → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers