/usr/share/kolla needs to be documented in docs/ansible-deployment.md

Bug #1471824 reported by Paul Bourke on 2015-07-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla
Low
Kuo-tung Kao (jelly)

Bug Description

On a fresh system running the ansible playbook results in the following error:

TASK: [database | Ensuring templates config directory exists] *****************
<localhost> REMOTE_MODULE file state=directory path=/usr/share/kolla/templates/mariadb
failed: [localhost] => {"failed": true, "parsed": false}
Traceback (most recent call last):
  File "/home/vagrant/.ansible/tmp/ansible-tmp-1436195999.51-172667771838553/file", line 2005, in <module>
    main()
  File "/home/vagrant/.ansible/tmp/ansible-tmp-1436195999.51-172667771838553/file", line 279, in main
    os.mkdir(curpath)
OSError: [Errno 13] Permission denied: '/usr/share/kolla'

FATAL: all hosts have already failed -- aborting

We should document that this needs to be set (node_templates_directory), or preferably default to somewhere writable by non root.

Sam Yaple (s8m) wrote :

Currently the playbooks require root. We do things like set sysctl settings and mess with directories owned by root.

The directory /usr/share/kolla _will_ be changed as default, but it will be changed to /var/lib/kolla and /opt/kolla will be changed to /etc/kolla.

This bug can be used to track the docs change to say the ansible-playbooks must be run as root since the defaults being changed is handled elsewhere.

Changed in kolla:
status: New → Confirmed
importance: Undecided → Low
Steven Dake (sdake) on 2015-08-29
Changed in kolla:
milestone: none → liberty-rc1
Steven Dake (sdake) on 2015-09-28
Changed in kolla:
milestone: liberty-rc1 → liberty-rc2
Changed in kolla:
assignee: nobody → jelly (coding1314)

Fix proposed to branch: master
Review: https://review.openstack.org/232381

Changed in kolla:
status: Confirmed → In Progress
Steven Dake (sdake) on 2015-10-11
Changed in kolla:
milestone: liberty-rc2 → liberty-rc3

Reviewed: https://review.openstack.org/232381
Committed: https://git.openstack.org/cgit/openstack/kolla/commit/?id=fd4f3747a0704ecff98e60a7d881bcad8de96915
Submitter: Jenkins
Branch: master

commit fd4f3747a0704ecff98e60a7d881bcad8de96915
Author: Kuo-tung Kao <email address hidden>
Date: Thu Oct 8 15:21:36 2015 +0800

    update doc for root is needed when deploying

    Update ansible-deployment to note that root privilege is needed
    when deploying.

    Change-Id: I80d3792de69c16c05c5285e8113d5924d6192735
    Closes-Bug: #1471824

Changed in kolla:
status: In Progress → Fix Committed
Sam Yaple (s8m) on 2015-11-20
Changed in kolla:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers