sudo kolla-ansible genconfig failed

Bug #1707856 reported by Chiawei Xie on 2017-08-01
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kolla-ansible
Undecided
Unassigned
kolla-kubernetes
Undecided
Unassigned

Bug Description

I followed this doc: https://docs.openstack.org/kolla-kubernetes/latest/deployment-guide.html

I used command sudo kolla-ansible genconfig , but got error message:

RUNNING HANDLER [mariadb : restart slave mariadb] ***********************************************************************************************
fatal: [localhost]: FAILED! => {"failed": true, "msg": "The conditional check 'inventory_hostname != master_host' failed. The error was: error while evaluating conditional (inventory_hostname != master_host): 'master_host' is undefined\n\nThe error appears to have been in '/usr/share/kolla-ansible/ansible/roles/mariadb/handlers/main.yml': line 44, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n- name: restart slave mariadb\n ^ here\n"}

Command failed ansible-playbook -i /usr/share/kolla-ansible/ansible/inventory/all-in-one -e @/etc/kolla/globals.yml -e @/etc/kolla/passwords.yml -e CONFIG_DIR=/etc/kolla -e action=config /usr/share/kolla-ansible/ansible/site.yml

My env:
OS: Centos7.3
Kernel: 4.12.4-1.el7.elrepo.x86_64

Lan Qi song (lqslan) wrote :

I tried to append "master_host: YOUR_HOSTNAME" into /etc/kolla/globals.yml to workaround this problem.
But I 'm not quite sure whether it's the right solution or not.

Mark Goddard (mgoddard) wrote :

Also seeing this. The problem is that master_host is set dynamically in bootstrap.yml but this is not executed during genconfig.

Eduardo Gonzalez (egonzalez90) wrote :
Changed in kolla-ansible:
status: New → Fix Released
milestone: none → queens-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers