Ceilometer fails to deploy when enable_swift=yes

Bug #1770415 reported by Paul Bourke on 2018-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kolla-ansible
Low
Unassigned

Bug Description

tools/kolla-ansible -i ~/multinode deploy --tags haproxy,mariadb,rabbitmq,keystone,ceilometer,gnocchi -e enable_swift=yes

TASK [ceilometer : Associate the ResellerAdmin role and ceilometer user] ***************************************************************************
fatal: [control01-upstream]: FAILED! => {"changed": false, "msg": "Role ResellerAdmin is not valid"}

caoyuan (cao-yuan) on 2018-05-11
Changed in kolla:
assignee: nobody → caoyuan (cao-yuan)
affects: kolla → kolla-ansible
Changed in kolla-ansible:
assignee: caoyuan (cao-yuan) → nobody
caoyuan (cao-yuan) on 2018-05-11
Changed in kolla-ansible:
assignee: nobody → caoyuan (cao-yuan)
caoyuan (cao-yuan) wrote :

you missing run swift role,
tools/kolla-ansible -i ~/multinode deploy --tags haproxy,mariadb,rabbitmq,keystone,ceilometer,gnocchi,swift -e enable_swift=yes can fix the error.

but we recommand to enable swift in /etc/kolla/globals.yml

Changed in kolla-ansible:
assignee: caoyuan (cao-yuan) → nobody
caoyuan (cao-yuan) on 2018-05-11
Changed in kolla-ansible:
status: New → Invalid
Paul Bourke (pauldbourke) wrote :

The issue is where I don't want to have Swift deployed. Arguably then I should have enable_swift set to False :) But it's still a hard to diagnose error that we should probably code against.

Changed in kolla-ansible:
status: Invalid → New
importance: Undecided → Low
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers