Kile consequently forgets some shortcuts on close

Bug #348662 reported by Arthur Schiwon on 2009-03-25
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kile
Fix Released
Medium
kile (Ubuntu)
Medium
Unassigned

Bug Description

The shortcuts setting (e.g. Alt+1 for Quick Build) as well as userdefined shortcuts with the same pattern (alt+figure) are being forgotten randomly (i guess every second start of kile, but i am quite not sure).
However, shortcuts with Ctrl or single function keys seem to be okay.

I use the ppa-package from Andreas Wenning on Kubuntu 8.10 (KDE 4.2.1), which is the same as in Jaunty.

Related branches

Thomas Braun (tbraun1234) wrote :

- Upstream link is https://bugs.kde.org/show_bug.cgi?id=187965.
- Confirmed.

Changed in kile:
importance: Undecided → Low
status: New → Triaged
Changed in kile:
status: Unknown → New
Changed in kile:
status: New → Confirmed
Uwe Schilling (uschilling) wrote :

Same problem here: kile forgets when I set the shortcut alt+2 for the latex compiler. This is very annoying, since I have automated this command in my workflow. Other shortcuts like ctrl+m for the align-environment are not affected.

Uwe Schilling (uschilling) wrote :

I have just read the upstream link and I do not agree that the bug described there matches the one reported here. Upstream, a bug is described where all the user-defined shortcuts vanish as soon as the ok-button in the kile-shortcuts-windows is pressed. In the bug reported here, the shortcuts work fine when defined via kile. However, they are gone when kile is restarted.

Arthur Schiwon (blizzz) wrote :

The upstream report dies not explicitly say that the shortcuts don't work after pressing OK, but the settings are removed from the file. It says after restarting, the shortcuts have vanished in kile.

Looks like some of this might already be fixed in upstream svn very recently. I have just uploaded a brand new svn snapshot to my PPA; can you test if the problem still exists there?
https://launchpad.net/~andreas-wenning/+archive/experimental

Uwe Schilling (uschilling) wrote :

Yes, it seems to be fixed indeed. At least I could not reproduce it on my machine anymore within two attempts (Before, the shortcuts did not just disappear randomly, but very reliably whenever I restarted the computer.).

Arthur Schiwon (blizzz) wrote :

Works for me as well.

I've uploaded a version that only contains the revision mentioned in the upstream bug. Can anyone confirm, that this version is enough to fix the problem:
https://launchpad.net/~andreas-wenning/+archive/ppa

Changed in kile (Ubuntu):
importance: Low → Medium
Uwe Schilling (uschilling) wrote :

I uninstalled kile (your first version of it) and reinstalled the official version via aptitude (this resulted in about 400 MB of other packages (probably mainly latex-packages) also being installed. Additionally, there were updates to some kdelibs, so I updated them. I cannot reproduce the bug anymore (I guess the updates to the kdelibs fixed it).

@Uwe
Please remove your kile settings file (rm ~/.kde/share/config/kilerc) and try to test again. Do you still get the problem or is it really gone? Which version do you have installed (apt-cache policy kile)?

Uwe Schilling (uschilling) wrote :

After removing the kile settings, the bug appeared again. For some reason, before I removed the kile settings, all Alt+Number would work the same way they used to in kile 2.0. Even for example Alt+1, for which I never defined a shortcut. However, after removing the settings, kile was again forgetting its shortcuts.

I added again your repository to my sources.list and updated kile. However, I'm not sure which version I actually installed, since there are two in your repository.
home@computer:~$ apt-cache policy kile
kile:
  Installiert: 1:2.1.0~svn954376-0ubuntu1~ppa3
  Kandidat: 1:2.1.0~svn954376-0ubuntu1~ppa3
  Versions-Tabelle:
 *** 1:2.1.0~svn954376-0ubuntu1~ppa3 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     1:2.1.0~svn942443-0ubuntu3 0
        500 http://de.archive.ubuntu.com jaunty/universe Packages

Uwe Schilling (uschilling) wrote :

However, the automatic line wrap was gone (I could recover it in the settings though) and I had a non-reproducible crash. I have attached the output from that crash.

Okay; i expected it to re-appear.

The package to test is in my other (non-experimental) ppa:
https://launchpad.net/~andreas-wenning/+archive/ppa
The version should end in ubuntu4~ppa1

Uwe Schilling (uschilling) wrote :

ups, sorry, hadn't noticed that it was another repository than the first time. Installed the version ubuntu4~pp11 and it's working fine.

Changed in kile:
status: Confirmed → Fix Released
Changed in kile (Ubuntu):
assignee: nobody → andreas-wenning
status: Triaged → In Progress

Debdiff with upstream's fix for this.

summary: - Kile forgets shortcuts randomly
+ Kile consequently forgets some shortcuts on close

Too late to be included in jaunty 9.04. This will have to wait for karmic 9.10 (maybe the fix can be backported when a stable release arrives).

Changed in kile (Ubuntu):
status: In Progress → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kile - 1:2.1.0~svn942443-0ubuntu4

---------------
kile (1:2.1.0~svn942443-0ubuntu4) jaunty; urgency=low

  * Add upstream rev. 952052; fixes kile forgetting shortcuts. (LP: #348662)

 -- Andreas Wenning <email address hidden> Fri, 17 Apr 2009 10:27:28 +0200

Changed in kile (Ubuntu):
status: Triaged → Fix Released
Scott Kitterman (kitterman) wrote :

ack from motu-release to go ahead.

I use the new package with jaunty rc, but the problem remains: kile always "forget" new settings for shortcuts!

Changed in kile (Ubuntu):
status: Fix Released → In Progress

@andschuster
If you take a bakcup of ~/.kde/share/config/kilerc (so you can restore it again if necessary) and delete it; does kile then still have problems remembering shortcuts?

Which version of kile do you use? Can be tested using:
apt-cache policy kile

Changed in kile (Ubuntu):
assignee: andreas-wenning → nobody
status: In Progress → Fix Released

@Andreas Wenning

Yes, kile also forgets shortcuts with an new kilerc.

output of apt-cache policy kile:

kile:
  Installiert: 1:2.1.0~svn942443-0ubuntu4
  Kandidat: 1:2.1.0~svn942443-0ubuntu4
  Versions-Tabelle:
 *** 1:2.1.0~svn942443-0ubuntu4 0
         500 http://de.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

I'm using 1:2.1.0~svn958896-0ubuntu1~ppa2 version and I found a related problem with User Tags shortcuts. (Latex menu-> User tags). (I found the same problem with 1:2.1.0~svn942443-0ubuntu4 0)

I created a new user tags and its shortcuts (ctrl+shift+1) works well until I close kile, but when I open kile again the shortcut doesn't work anymore. I have to click on Latex menu-> User tags and just click over APPLY button to see shortcut works again.

can anyone confirm this bug?

Changed in kile:
status: Fix Released → Confirmed
Eero Aaltonen (ejn) wrote :

I tried installing from here
https://launchpad.net/~andreas-wenning/+archive/ppa

Version 1:2.1.0~svn963524-1ubuntu1~jaunty1~ppa2

It did not fix the missing shortcuts.

next I tried removing ~/.kde/share/config/kilerc
, which ended up with kile crashing fatally at startup

I then proceeded to completely remove kile with synaptic and install again from
https://launchpad.net/~andreas-wenning/+archive/ppa

now none of the actions "compile", "convert", "view" are available.

Any suggestions as to what to do next?

Matthias (prandtstetter) wrote :

Hi there,

almost the same applies for me - although I installed the fixed version and removed the old kilerc Kile still forgets the shortcuts for building.
For a short while "compile", "convert", "view", ... were not available for me too. A few restarts of kile solved this problem.

I am using Jaunty 64bit (stable version) plus the fix of kile.

So, I think there is still a bug hidden somewhere. Anyhow, thanks for Kile (and the work dedicated to it).

Regards,
Matthias

Changed in kile:
status: Confirmed → Fix Released
koro (akoropecki) wrote :

I have

kile: Installed: 1:2.1.0~svn942443-0ubuntu4.1

and the problem described in this bug is happening to me.

Mander (arwintcher) wrote :

apt-cache policy kile
kile:
  Installed: 1:2.1.0~svn981319beta1-0ubuntu0~jaunty1~ppa1
  Candidate: 1:2.1.0~svn981319beta1-0ubuntu0~jaunty1~ppa1
  Version table:
 *** 1:2.1.0~svn981319beta1-0ubuntu0~jaunty1~ppa1 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     1:2.1.0~svn942443-0ubuntu4.1 0
        500 http://gb.archive.ubuntu.com jaunty-updates/universe Packages
     1:2.1.0~svn942443-0ubuntu4 0
        500 http://gb.archive.ubuntu.com jaunty/universe Packages

Kile now remembers the shortcuts, but it now won't let me change them. I tried to assign Alt+2 to LaTex, but I get an error message that this is assigned to PdfLaTex and I have to choose another. I tried assigning Alt+4 to PdfLaTex, and it appears as such in the Build menu, but Alt+2 does nothing.

In the settings menu, PdfLatex does not appear to have a shortcut at all.

Mander (arwintcher) wrote :

I am still having a problem with shortcuts. Although I can sort-of assign new ones, Kile still gives me the message that alt+2 is for pdflatex, even though I have changed them both (and alt+2 does not appear to be assigned to anything at all in the shortcuts dialog box).

I have tried removing my preferences, per the instructions above, but it makes no difference at all. I also tried creating a new shortcuts file but then I find that I cannot use the keyboard in kile.

kile:
  Installed: 1:2.1.0~svn1055245beta3-0ubuntu0~jaunty1~ppa2
  Candidate: 1:2.1.0~svn1055245beta3-0ubuntu0~jaunty1~ppa2
  Version table:
 *** 1:2.1.0~svn1055245beta3-0ubuntu0~jaunty1~ppa2 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     1:2.1.0~svn942443-0ubuntu4.1 0
        500 http://gb.archive.ubuntu.com jaunty-updates/universe Packages
     1:2.1.0~svn942443-0ubuntu4 0
        500 http://gb.archive.ubuntu.com jaunty/universe Packages

Leo (leorolla) wrote :

I can confirm this problem is still present in Karmic:

kile (1:2.1.0~svn1014763beta2-1ubuntu1)

Changed in kile (Ubuntu):
status: Fix Released → Confirmed

Please test with the version from the upcoming lucid lynx release. Alternatively a backported version is available in my PPA. Also try after removing the preferences as per above. Does it still fail in beta4 after removing the preferences?

Changed in kile (Ubuntu):
status: Confirmed → Incomplete
Leo (leorolla) wrote :

With beta2, after removing the preferences, the problem persists.
Maybe it could be marked Won't Fix for Karmic so that other people don't reopoen the bug?
I will test with Lucid soon and report later.

Leo (leorolla) on 2010-04-21
Changed in kile (Ubuntu):
status: Incomplete → Confirmed
David Futcher (bobbo) on 2010-06-09
tags: added: patch-accepted-upstream
Sebastien Bacher (seb128) wrote :

setting to needswork since the patch is in the current version but users still get the issue

tags: added: patch-needswork
removed: patch-accepted-upstream
Changed in kile:
importance: Unknown → Medium
Vibhav Pant (vibhavp) on 2012-04-22
Changed in kile (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.