Project template file not found

Bug #674237 reported by David on 2010-11-11
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

When creating a new project, after selecting a directory for the project an Info dialog pops up stating:
"Project template file <kicad.pro> not found"
and then and Error
"Kicad project file <PATH/TO/FILE> not found"

Software:
Kicad 2010-05-17 BZR 2382 (from http://kicad.xor-gate.org/)
Mac OS 10.6.4 clean install

Hardware:
MacBook late 2007
4GB ram

ZdenoQC (williamdeshaies) wrote :

Workaround:

Create a new document
After failure, click the save button
Click on refresh
The <nameofproject>.pro is created

Software:
Kicad 2012-01-10 BZR 3351 (from http://kicad.xor-gate.org/)
Mac OS 10.7.3 Lion

Hardware:
Macbook pro late 2011
4GB ram

Martin Errenst (imp-d) wrote :

Cannot reproduce this bug with the current version of KiCad (r4714).
After choosing an directory, it'll either create the .pro file in it, or if it's not empty, ask you if it should create an empty subdircetory and place the .pro file there (if yes, if no, it'll put it into the directory you've selected first).

Changed in kicad:
status: New → Fix Committed
Berk Akinci (berka) wrote :

I just came across this problem w/ r4721.

Workaround worked too. The workaround scared me into thinking I overwrote the last-opened project which was still displayed as if it was open.

KiCad Build (2014-02-26 BZR 4721)-product
MacOSX Mavericks on MacBook Air 2013.
Build and library downloaded from:
http://www.mdx4.org

firewalker (firew4lker) wrote :

Just came across it with the last bzr versions on Linux. r4780 to r4791.

Changed in kicad:
status: Fix Committed → Fix Released
Robert Powers (rdpowers) wrote :

I still get this in BZR 4793 (09/04/2014) on Linux - is the fix supposed to be in by this point? Or am I not understanding the 'Fix Released' status properly?

Philip (rocketman768) wrote :

Issue still happens in 2014-04-13 BZR 4800, installed from the installer script.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers