Trapeziodal pads are buggy

Bug #632355 reported by Robert
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
Undecided
jean-pierre charras

Bug Description

I've found a couple of problems with trapezoidal pads that have resulted in significant problems routing a board.

Firstly the DRC outline is not the same shape as the pad, so sometimes the minimum allowable distance to the pad is greater than the track spacing dimension (clearance), and sometimes it's less. Both make tracking problematic. The attachment shows (top) some random pads in the module editor and (bottom) a SOT89 in PCBNew (clearance set to 0.1956mm, grid to 0.01mm).

Secondly trapezoidal pads in designs exported to Freerouter get imported as ovals, which being a completely different shape result in Freerouter being unable to route the board. That may be a bug in Freerouter, of course, but I have no means of knowing where the bug lies.

PCBNew (2010-05-05 BZR 2356)-stable / XP Pro SP3.

Revision history for this message
Robert (birmingham-spider) wrote :
Revision history for this message
Lorenzo Marcantonio (l-marcantonio) wrote : Re: [Bug 632355] [NEW] Trapeziodal pads are buggy

On Tue, 7 Sep 2010, Robert wrote:

> being unable to route the board. That may be a bug in Freerouter, of
> course, but I have no means of knowing where the bug lies.

I think that freerouter doesn't support trapezoidal pads (or maybe it's
the underlying DSN file which can't handle them). Anyway I checked and
they're exported as round.

--
Lorenzo Marcantonio
Logos Srl

Revision history for this message
Robert (birmingham-spider) wrote :

Thanks for taking a look. If trapezoidal pads are not supported by the DSN format and / or Freerouter it would be helpful if a warning message box was displayed when creating the DSN file; I left a PC grinding away for a couple of days trying to route the board before I noticed what was wrong.

Revision history for this message
Dick Hollenbeck (dickelbeck) wrote : Re: [Bug 632355] Re: Trapeziodal pads are buggy

I'm spending some time this morning looking into this.

Dick

Revision history for this message
Dick Hollenbeck (dickelbeck) wrote :

Enhancement added in rev 2477 to handle trapezoidal pads in the specctra export.

Changed in kicad:
status: New → Fix Committed
Revision history for this message
Dick Hollenbeck (dickelbeck) wrote :

Committed version 2479 to overcome a mirror image problem that came about because my original testing was done using an SMT component on the BACK side of the board.

I got bit by a bug in freerouter, which is not showing trapezoidal pads existing on the back side of the board properly. If you use a simple SMT pad existing on a single side within the footprint, then export this to freerouter, you can see it now draws the pad properly if the component is on the front side of the board, but not properly if the component is flipped over onto the back side of the board.

Robert, please file a bug report with freerouter for me as a reciprocal favour. Link to this posting if you want.

Revision history for this message
Robert (birmingham-spider) wrote :

Thanks, Dick. I've posted a bug report on the Freerouter forum and will report back any significant replies here.

Did you take a look at the problem of the DRC area being the wrong shape from trapezoidal pads? I can resubmit that as a separate bug report if that's helpful.

Revision history for this message
Dick Hollenbeck (dickelbeck) wrote :

I am reopening this since the DRC problem is still pending. Someone with a vested interest can volunteer to fix this DRC issue, I don't currently have such an interest.

Changed in kicad:
status: Fix Committed → Confirmed
Changed in kicad:
status: Confirmed → In Progress
assignee: nobody → jean-pierre charras (jp-charras)
Revision history for this message
Dick Hollenbeck (dickelbeck) wrote :

http://www.freerouting.net/fen/viewtopic.php?f=5&t=100#p361

Alfons says he has fixed his end of this.

The only remaining issue was the DRC spacing, which if it was fixed, was not logged in the bug report.

Revision history for this message
jean-pierre charras (jp-charras) wrote :

Should be fixed now.
Need more tests.

Changed in kicad:
status: In Progress → Fix Committed
Revision history for this message
Robert (birmingham-spider) wrote :

Sorry, Dick, I was going to alert you to any activity in response to my post, but I didn't get any notifications from the forum (not even in my spam folder). Just went to test the various modifications myself using the latest snapshot at http://kicad.1301.cz, but there was no change. Are you able to tell me when the modifications will appear in the snapshots?

Revision history for this message
Dick Hollenbeck (dickelbeck) wrote :

On 09/23/2010 08:23 AM, Robert wrote:
> Sorry, Dick, I was going to alert you to any activity in response to my
> post, but I didn't get any notifications from the forum (not even in my
> spam folder). Just went to test the various modifications myself using
> the latest snapshot at http://kicad.1301.cz, but there was no change.
> Are you able to tell me when the modifications will appear in the
> snapshots?
>

No, I am disconnected from snapshots. The change was committed into
the testing branch, and others take it from there.

Dick

Revision history for this message
jean-pierre charras (jp-charras) wrote :

Le 23/09/2010 15:23, Robert a écrit :
>
> Sorry, Dick, I was going to alert you to any activity in response to my
> post, but I didn't get any notifications from the forum (not even in my
> spam folder). Just went to test the various modifications myself using
> the latest snapshot at http://kicad.1301.cz, but there was no change.
> Are you able to tell me when the modifications will appear in the
> snapshots?
>

Are you missing the bug status change: now a fix is committed.
This issue is now fixed in the testing branch.

--
Jean-Pierre CHARRAS

Jon Neal (reportingsjr)
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments