Reference and value of component not fully uploaded after editing in EESchema

Bug #586032 reported by distressfull on 2010-05-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

After attemp to init reference of component in EESchema for example from R? to R100 there is displayed correct reference (R100) but netlist generator report a fail. New attempt for editing showed that reference is in real R? and not R100. To save a project is unefficient. EESchema must be restarted for correct change upload.

Dick Hollenbeck (dickelbeck) wrote :

You do not state the version of the software, the operating system, nor the exact steps to reproduce the problem. By exact steps, this would entail the names and fields of dialog boxes, menu choices, and exact keystrokes.

Changed in kicad:
status: New → Incomplete

I remember that I got a similar bug but I was unable to reproduce.
I investigated and I am now able to do.
This bug is vicious and occurs in the undo feature.

To follow the changes in the component reference, open the netlist file in a text editor.

In eeschema, ref is R1, in netlist file, ref is R1
In eeschema, change ref R1 to R2, create netlist, in netlist file, ref is R2
In eeschema, change ref R2 to R3, create netlist, in netlist file, ref is R3
In eeschema, change ref R3 to R4, create netlist, in netlist file, ref is R4
In eeschema, change ref R4 to R5, create netlist, in netlist file, ref is R5
In eeschema, undo action (Ctrl+Z), create netlist: eeshema display R4, in netlist file, ref is R5
In eeschema, undo action (Ctrl+Z), create netlist: eeshema display R3, in netlist file, ref is R5
Previous behaviour is the same with or without saving schematic file.
Save the file, quit eeschema, run eeschema, ref is R3, create netlist, in netlist file, ref is R3.

Changed in kicad:
status: Incomplete → Fix Committed
Martin Errenst (imp-d) wrote :

r2386 stable

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers