Eeschema in Kicad 5.1.2 wrong input language on keyboard input

Bug #1849801 reported by Michael on 2019-10-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Incomplete
Undecided
Unassigned

Bug Description

My Windows is running in German and I'm working with the German version of KiCad 5.1.2.

While adding a networklabel in Eeschema I noticed the characters on my keyboard were swapped to English keyboard layout. So I rechecked if everything else works fine and indeed it's only in Eeschema that I need to use shift+ß to create an _ .

Application: kicad
Version: (5.1.2)-1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Wayne Stambaugh (stambaughw) wrote :

Is this still the case with the latest stable release 5.1.4? I'm guessing it is but I have no way of testing this.

Changed in kicad:
status: New → Incomplete
tags: added: eeschema
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers