Unexpected behaviour with Pcbnew manual routing

Bug #1849613 reported by Bogdan Șerban on 2019-10-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
Incomplete
Undecided
Unassigned

Bug Description

Manual routing sometimes gives weird results. I have attached examples below to better explain it, but the idea is that I get weird track shapes when I clearly shouldn't. I would expect the track to follow my mouse movements without me having to add unnecessary points, and without adding those 90 degree angles.
I'm not sure exactly what version introduced this behaviour, but I suspect this has been introduced in 5.1, it wasn't like this before.

Example 1:

https://imgur.com/AuGulBh

Example 2:

https://imgur.com/Ou6Eq69

Version info:

Application: KiCad
Version: 5.1.4, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.66.0 OpenSSL/1.1.1d zlib/1.2.11 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh2/1.8.2 nghttp2/1.39.2
Platform: Linux 5.3.7-arch1-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.71.0
    OpenCASCADE Technology: 7.4.0
    Curl: 7.66.0
    Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=ON
    KICAD_SPICE=ON

eelik (eelik) wrote :

This was the original forum thread: https://forum.kicad.info/t/why-did-routing-become-so-annoying/19493

As I said there, I would expect KiCad to offer two 45 degree corners instead of 90 + 45 degrees by default when it can choose between those.

Seth Hillbrand (sethh) wrote :

Thank you for the report. Please add the files as attachments to the bug report. I am unable to view imgr links.

tags: added: pcbnew
tags: added: pns
Changed in kicad:
status: New → Incomplete
Felix Vollmer (felixvollmer) wrote :
Felix Vollmer (felixvollmer) wrote :
Felix Vollmer (felixvollmer) wrote :

I attached the imgur images to the bug report and reopened the bug report

Changed in kicad:
status: Incomplete → New
Seth Hillbrand (sethh) wrote :

I suspect that this is resolved in master.

If it is not, please attach the board file that exhibits the behavior and a screen shot of your Interactive Router settings.

Changed in kicad:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers