Connection when symbol placed on wire

Bug #1849376 reported by Franck Jullien on 2019-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Fix Committed
Low
Franck Jullien

Bug Description

Version: 5.99.0-unknown-da28426~100~ubuntu18.04.1, release build

When a place a symbol on a wire, directly after I selected it from the library, connection is not made. I need to move the symbol back and on again to get a connection.

See forum post: https://forum.kicad.info/t/connection-when-symbol-placed-on-wire/19511

Franck.

Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

Please copy the full version information from About KiCad -> Copy Version Info.

Changed in kicad:
status: New → Incomplete
tags: added: eeschema
Revision history for this message
Franck Jullien (fjullien) wrote :

Here it is:

Application: Eeschema
Version: (5.99.0-277-g9c1c609fa), debug build
Libraries:
    wxWidgets 3.0.4
Platform: Linux 4.15.0-66-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    Build date: Oct 30 2019 16:51:55
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
    Boost: 1.65.1
    Compiler: GCC 7.4.0 with C++ ABI 1011
Build settings:
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=OFF
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON
    KICAD_STDLIB_DEBUG=OFF
    KICAD_STDLIB_LIGHT_DEBUG=OFF
    KICAD_SANITIZE=OFF

Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

How many pins does the symbol have? IIRC this was added for two pin devices some time ago.

Revision history for this message
Franck Jullien (fjullien) wrote :

It has two pins. I updated the link in my forum post.
You can see an animated gif showing the problem.

Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

Please, in future, upload all images/videos/gifs etc. directly to the Launchpad bug tracker. It helps in the future when external links inevitably break :)

Application: Eeschema
Version: (5.99.0-388-geadcb5de5), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.64.1 SecureTransport (LibreSSL/2.8.3) zlib/1.2.11 nghttp2/1.39.2
Platform: Mac OS X (Darwin 19.0.0 x86_64), 64 bit, Little endian, wxMac
Build Info:
    Build date: Nov 17 2019 18:30:33
    wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8)
    Boost: 1.70.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.54.0
    Compiler: Clang 11.0.0 with C++ ABI 1002

Build settings:
    KICAD_SCRIPTING=OFF
    KICAD_SCRIPTING_MODULES=OFF
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON
    KICAD_STDLIB_DEBUG=OFF
    KICAD_STDLIB_LIGHT_DEBUG=OFF
    KICAD_SANITIZE=OFF

Changed in kicad:
importance: Undecided → Low
milestone: none → 6.0.0-rc1
status: Incomplete → Triaged
Revision history for this message
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision a5f8340654f98af989d3825f7d4fa0bef4541e97
https://git.launchpad.net/kicad/patch/?id=a5f8340654f98af989d3825f7d4fa0bef4541e97

Changed in kicad:
status: Triaged → Fix Committed
assignee: nobody → Franck Jullien (fjullien)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers