PCBNew: Position of part lost when updating footprint

Bug #1838446 reported by DDuck007 on 2019-07-30
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
High
jean-pierre charras

Bug Description

Performing Update-footprints (e.g. "Update all footprints on board" or "Update selected footprint" or selecting "Update PCB from schematic") in PCBNew the positions of the parts are lost and all parts are located one over the other at cursor-position.
Problem found in version 5.1.3, in version 5.1.2_2 update is working as expected without changing position of part at the board.

Application: KiCad
Version: (5.1.3-11-gc8278f377)-5.1.3, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.65.0 OpenSSL/1.1.1b (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.1.1 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.38.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.70.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.65.0
    Compiler: GCC 8.3.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Revision history for this message
Ian McInerney (imcinerney) wrote :

I do not see this behavior when I use the update PCB from schematic tool, in that tool only the footprints that have been modified in the schematic are updated and moved.

I do see that every footprint is moved to the cursor when using the dedicated update footprint window to update all footprints (see attached screen capture showing this for an individual footprint and for all footprints).

This does not happen in the 5.1.2-1 from the Fedora repository I have installed, so it is a regression from then.

This does not seem to happen on the master branch.

Application: Pcbnew
Version: (5.1.3-11-gc8278f377), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.64.0 OpenSSL/1.1.1c zlib/1.2.11 brotli/1.0.7 libidn2/2.1.1 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.8.7/openssl/zlib nghttp2/1.37.0
Platform: Linux 5.1.18-300.fc30.x86_64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.69.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.65.3
    Compiler: Clang 8.0.0 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Changed in kicad:
status: New → Confirmed
Jeff Young (jeyjey) on 2019-07-30
Changed in kicad:
importance: Undecided → High
tags: added: pcbnew
Changed in kicad:
milestone: none → 5.1.4
Revision history for this message
Nick Østergaard (nickoe) wrote :

In Version: (5.1.3-10-gd34b66493), release build I also see that "update" footprints are moved to a common origin instead of being updated in-place. I think this could be an option in "Update PCB from Schematic" dialog.

Maybe a checkbox to "Leave update footprints in place" or "Place footprints at cursor" after the apply step. This do look like a bug because all the updated footprints are located at the last location where the cursor was on the canvas and not spread out like when importing new footprints.

Revision history for this message
Nick Østergaard (nickoe) wrote :

I can confirm that 5.1.2 do perform update in-place as expected.

Changed in kicad:
status: Confirmed → Fix Committed
assignee: nobody → jean-pierre charras (jp-charras)
Revision history for this message
Nick Østergaard (nickoe) wrote :

The same happens for the update footprints via the right click menu to update it from the library.

Revision history for this message
Nick Østergaard (nickoe) wrote :

I can confirm that 090073cc3b79f4f646f3c82390eb02a253e488d8 fixes the issue. Thank you JP :)

Revision history for this message
Jeff Young (jeyjey) wrote :

Ooops, that was my bad. Thanks, JP!

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers