UI issues in select layer pair dialog

Bug #1838173 reported by Oleg Endo on 2019-07-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
Low
jean-pierre charras

Bug Description

Like the title says, please see the attached screenshot. That's how it looks here on Ubuntu 18. Not sure if that's good or bad :)

Application: KiCad
Version: 6.0.0-unknown-2af41e8~86~ubuntu18.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-54-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.58.0
    Compiler: GCC 7.4.0 with C++ ABI 1011

Build settings:
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Revision history for this message
Oleg Endo (oleg.endo) wrote :
Revision history for this message
Ian McInerney (imcinerney) wrote :

Hmm, I don't see the black background on my version (the two lists have white backgrounds) but there are some UI issues in the dialog. The layer lists are cutoff in my version since the cells are not wide enough.

I think the coloring issue could be fixed similar to a way JP fixed this on the statistics dialog in commit 88801f46d92f46a337c66d77027a1f185472e243.

summary: - select layer pair dialog looks weird
+ UI issues in select layer pair dialog
tags: added: pcbnew ui
Changed in kicad:
status: New → Confirmed
Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

I assume this is also present in 5.1? Please adjust the milestone if not.

Changed in kicad:
importance: Undecided → Low
milestone: none → 5.1.4
Revision history for this message
Ian McInerney (imcinerney) wrote :

The cutoff text is present in 5.1.4, and I would assume the background is also because that dialog code was last touched in mid 2018.

Revision history for this message
Ian McInerney (imcinerney) wrote :

(I meant present in 5.1.3)

Revision history for this message
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision dc69cac29831791efc9d161adee6fa7f064afc12
https://git.launchpad.net/kicad/patch/?id=dc69cac29831791efc9d161adee6fa7f064afc12

Changed in kicad:
status: Confirmed → Fix Committed
assignee: nobody → jean-pierre charras (jp-charras)
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers