search text on pcbnew

Bug #1838006 reported by m on 2019-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
Wishlist
Jeff Young

Bug Description

In PCBnew, it is possible to search using 'CTRL F' for Reference Fields
It is not possible to search for simple Text fields.
It is common to put some text annotation on pcbnew like i.e. on comments layer... it would be useful to let the search work also on 'gr_text' fields or even on title_block elements.

Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

Please copy the full version information from About KiCad -> Copy Version Info.

Changed in kicad:
status: New → Incomplete
Revision history for this message
m (easyw) wrote :

Hi @michaelkavanagh,
no need to detail the kicad info.
This is a feature missing from 3 to actual nigthly.

m (easyw) on 2019-07-26
Changed in kicad:
status: Incomplete → New
Revision history for this message
Nick Østergaard (nickoe) wrote :

@m, which is not mentioned in the original bug description

Revision history for this message
m (easyw) wrote :

@nickoe
instead of just putting this bug as incomplete, @michaelkavanagh could have checked if this was or not present... or just ask for a clarification without marking this imo...

Anyway this is a bug that affects pcbnew since v3.

Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

The KiCad bug reporting guidelines, displayed on the bug report form, states "The single most important step is to paste the version information from KiCad into your bug report. This is accomplished by selecting the Help->Copy Version Information main menu entry in the main window where the bug is occurring. This includes most of the information about you build of KiCad." [1]. This is also repeated on the KiCad Website [2].

This information is required for all bug reports submitted (even if they are Wishlist items), and therefore the bug report will be labelled as incomplete until it is provided. It is important to determine if/where the bug was introduced and what changes may have caused it.

I actually did verify the bug before marking it as incomplete, but platform differences can change behaviour in some cases and comparing the version information helps triage the bug.

[1] https://bugs.launchpad.net/kicad/+filebug
[2] http://kicad-pcb.org/help/report-a-bug/

Revision history for this message
m (easyw) wrote :

>> I actually did verify the bug before marking it as incomplete, but platform differences can change behaviour in some cases and comparing the version information helps triage the bug.

Then you could have added your platform and version details and marked as confirmed on those.

Anyway this is simply not working on all platforms, because no source code is addressing gr_text or title blocks for searching text.

Revision history for this message
Seth Hillbrand (sethh) wrote :

Hi Maurice-

Michael is correct here. The reason we require the version information -- even for wishlist items -- is that they might not get addressed for a while. Or someone may implement it, not knowing of the bug report. Then, as we clean out the old reports, the person testing will not know which platform and which version of the nightly build the original report was from.

Each developer working on a report will spend at least an hour implementing and testing the code that addresses your request. We only ask that you help us by contributing the extra 30 seconds to copy and paste the version information that makes our work easier.

Thanks!

Revision history for this message
m (easyw) wrote :

Hi Seth
I don't want to be polemic, but do you really think that adding a single platform and version would be more exhaustive than the report I did?
"All release version since v3 (nightly included), all platforms"
Anyway I will put some extra (but less relevant) details asap.

Revision history for this message
Jeff Young (jeyjey) wrote :

I have to agree with Seth and Michael here. When I look at this bug two years from now it will take me a lot longer to figure out what the current version was when it was reported then it would for the OP to put the version info in.

Revision history for this message
Jeff Young (jeyjey) wrote :

I've rewritten the PCBNew find dialog for 6.0. It now supports:

1) searching in user-defined footprint fields
2) searching in pcb text
3) a history list in the search popup
4) case sensitive searching
5) word sensitive searching
6) the ability to turn wildcard searching on/off
7) better placement of the result when the dialog obscures part of the window

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 6.0.0-rc1
status: New → In Progress
status: In Progress → Fix Committed
Revision history for this message
Jeff Young (jeyjey) wrote :

I've cherry picked (1) and (2) back to 5.1. The others are much larger changes.

Revision history for this message
m (easyw) wrote :

I'm glad the focus is now on cooperation and solve bugs :D
Thanks for the fix.

Here one of the version of the sw with the bug:
Application: Pcbnew
Version: 5.1.3-ffb9f22~84~ubuntu18.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-55-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.58.0
    Compiler: GCC 7.4.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Changed in kicad:
importance: Undecided → Wishlist
Revision history for this message
m (easyw) wrote :

Hi @jeyjey
> I've cherry picked (1) and (2) back to 5.1. The others are much larger changes.

it seems your cherry picked code doesn't address pcb text
https://github.com/KiCad/kicad-source-mirror/commit/6aeedfb70c164524992cded6b997df2a0452af06#diff-4732a4aac335e18bb786fa906bc7a8deR154
you are filtering for 'PCB_MODULE_TEXT_T' instead of 'PCB_TEXT_T'
on 'BOARD_ITEM* item : parent->GetBoard()->Drawings()'

Revision history for this message
Jeff Young (jeyjey) wrote :

Yeah, that's not going to work very well, is it? I wonder if master has the same error....

Changed in kicad:
status: Fix Committed → In Progress
Revision history for this message
Jeff Young (jeyjey) wrote :

Fix merged.

@m, thanks for doing the legwork!

Revision history for this message
Jeff Young (jeyjey) wrote :

(Note: master did not have the error.)

Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

Fixed in 4b01f80e8d7acd99764b4c3f79b5bdee2d6c4411

Changed in kicad:
milestone: 6.0.0-rc1 → 5.1.4
status: In Progress → Fix Committed
Revision history for this message
m (easyw) wrote :

@jeyjey,
thanks :)

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers