pcbnew: plot Drill Map always in inches

Bug #1836924 reported by Eldar Khayrullin on 2019-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
Low
Ian McInerney

Bug Description

Current branch 5.1.

Revision history for this message
Seth Hillbrand (sethh) wrote :

Please add your KiCad version information.

no longer affects: kicad/5.0
no longer affects: kicad/stable
Changed in kicad:
status: New → Incomplete
Revision history for this message
Eldar Khayrullin (eldar) wrote :

Application: KiCad
Version: 5.1.2-br-unknown-02d43be~84~ubuntu18.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-54-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.58.0
    Compiler: GCC 7.4.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Changed in kicad:
status: Incomplete → New
Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

Can you provide more detailed instructions/a video recording? Mine seem to be in mm / in format.

Changed in kicad:
status: New → Incomplete
Revision history for this message
Eldar Khayrullin (eldar) wrote :

@michael Try to import to pcbnew generated drill map dxf and it will be small

Revision history for this message
Michael Kavanagh (michaelkavanagh) wrote :

The import scaling bug seems familiar but I cannot find it in the bug tracker. I can confirm exported/plotted DXF drill maps are identical irregardless of the unit selected in the dialog, and importing them back into pcbnew results in a tiny graphic.

Changed in kicad:
importance: Undecided → Low
milestone: none → 5.1.4
status: Incomplete → Confirmed
Revision history for this message
Ian McInerney (imcinerney) wrote :

Ah, DXF export units... they are the gift that keep on giving.

Looks like we missed this in the DXF units work for 5.1.3, but here is a patch that should fix this. It also looks like the export units never worked (like the rest of the DXF units infrastructure until now)...

The DXF import issue looks similar to this: https://bugs.launchpad.net/kicad/+bug/1819283.

Changed in kicad:
assignee: nobody → Ian McInerney (imcinerney)
Revision history for this message
Wayne Stambaugh (stambaughw) wrote :

@Ian, does this bug exist in the master branch?

Revision history for this message
Ian McInerney (imcinerney) wrote :

@Wayne, yes it affects both branches.

Revision history for this message
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 6c401ecce7f65ea4a96f3d002e071cda422f5c30
https://git.launchpad.net/kicad/patch/?id=6c401ecce7f65ea4a96f3d002e071cda422f5c30

Changed in kicad:
status: Confirmed → Fix Committed
Revision history for this message
Wayne Stambaugh (stambaughw) wrote :

@Ian, I merged your patch into the master and 5.1 branches. Thanks!

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers