PCBNew crash when updating PCB from Schematic

Bug #1831513 reported by Timothy Abraham on 2019-06-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Critical
Unassigned

Bug Description

Pcbnew crashed whenever I try to use the "Update PCB from Schematic" Button.

Tried with a fresh project.
 - Create project "OLED_Breakout"
 - add part (Screw_Terminal_01x02)
 - add footprint (TerminalBlock:TerminalBlock_bornier-2_P5.08mm)
 - Annotate schematic
 - Save Schematic
 - Click "Run Pcbnew" button
 - Click "Update PCB from Schematic
 - CRASH

Application: KiCad
Version: (5.1.0-815-gf49779465), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jon Evans (craftyjon) wrote :

Hi Timothy, I think this crash has already been fixed, f49779465 is a few days old and that particular build was in the middle of a big change set that is still settling out. Can you try again on a newer build?

Timothy Abraham (timmit99) wrote :

Aaah, OK. i searched and didn't find anything. Let me download the newer build and try it! thanks!

Timothy Abraham (timmit99) wrote :

That fixed it! Sorry, didn't see anything referencing this issue so thought id throw up a bug track!

Jon Evans (craftyjon) wrote :

No worries, always better to have the info in the tracker in case it shows up again.

Changed in kicad:
status: New → Fix Committed
milestone: none → 6.0.0-rc1
importance: Undecided → Critical
tags: added: eeschema pcbnew
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers