EESchema copy of text vanishes when editing the original

Bug #1825641 reported by Anton on 2019-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

Whatch the video

Anton (antonpupkov) wrote :
Rene Poeschl (poeschlr) wrote :

I can not reproduce this in kicad 5.1.1 under ubuntu 16.04.

Could you add your version info?

Changed in kicad:
status: New → Incomplete
summary: - EEScema text box works abnormally
+ EESchema copy of text vanishes when editing the original
Anton (antonpupkov) wrote :

Application: kicad
Version: (5.1.0-291-gc5effadb2), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.63.0 OpenSSL/1.1.1a zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.34.0
Platform: Linux 4.19.8-arch1-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.63.0
    Compiler: GCC 8.2.1 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Anton (antonpupkov) wrote :

The text field lives its own life)

Anton (antonpupkov) wrote :

The error manifests itself when you copy (via button C, context menu), transfer (via button M), for some reason you need to click several times to place, then the copy disappears when you try to double click on it.

Wayne Stambaugh (stambaughw) wrote :

Would it be possible for you to test this using version 5.1.2? I cannot duplicate this on the latest 5.1 branch. It could be an issue with gtk2 as I am using gtk3 on my linux builds.

Anton (antonpupkov) wrote :

In my opinion, everything is much simpler. I used the git version of the program. I came to the conclusion that the overwhelming majority of errors occur for a banal reason and only in the git-version. Because in the place where errors occur, the work on one or another component has not yet been completed, it has not been brought to its logical conclusion. It is more expedient to react to bugs in the release versions (not in the git version), where all the work on the bug fixes and changes has been completed. In release 5.1.2, everything is fine with the text field. There are no such problems.
Release 5.1.2 is stable, with the exception of some artifacts from ratsnest and one crash. Users must use only latest release version, not latest git snapshot.

Anton (antonpupkov) wrote :

As for the bug, you can write fix committed and so on.

Changed in kicad:
status: Incomplete → Fix Released
Wayne Stambaugh (stambaughw) wrote :

@Anton, we still need bug reports filed against nightly builds not just release builds. This helps us keep the nightly builds as usable as possible. That's why it is critical to include the version information in bug reports so we don't waste time trying to determine in which branch a bug exists.

Changed in kicad:
status: Fix Released → Fix Committed
milestone: none → 6.0.0-rc1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments