Pcbnew crash on start

Bug #1825605 reported by Mikhail Terekhin on 2019-04-20

This bug report will be marked for expiration in 34 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

Pcbnew crashes on launch. It happens both when creating a new pcb or when opening an existing one. Im using wingows 64 bit version 5.0.1-4 (OS is win 10). The issue started around 2 weeks ago, before that everything worked flawlessly. I tried rolling back to a different update, however that didnt fix the bug. I have kicad on my linux machine aswell and there pcbnew works without any crashes.

Please update to the latest stable (5.1.0) as the 5.0.0 series is no longer supported.

Then, please copy the full version information from About KiCad -> Copy Version Info.

Are you launching Pcbnew standalone or from the KiCad manager (in a project)?

Since it used to work and now it doesn't suggests there was a change on your machine that caused this.

Changed in kicad:
status: New → Incomplete

I have updated to 5.1.0_1 however the issue is still present. Im launching pcbnew from kicad launcher, however I tried to launch it standalone and got same result. I didnt make any changes on my PC on purpose, however ive added external parts library to kicad. The library however works on ubuntu, so it should not be the issue.
Full version information:

Application: kicad
Version: (5.1.0)-1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jon Evans (craftyjon) on 2019-04-20
Changed in kicad:
status: Incomplete → New
Nick Østergaard (nickoe) wrote :

Did you happen to add any scripts?

Please check if you have any scripts in %APPDATA%/kicad

No, at least, dont remember adding any.
Files in the folder:
bitmap2component
eeschema
fp-lib-table
gerbview
kicad
kicad_common
KicadFrame.hotkeys
pcbnew
PcbNew.hotkeys
sym-lib-table
+ an empty 3d folder

Ive found a solution to my problem! All i needed to do is to delete pcbnew related files from %appdata%/kicad. I guess they gor corrupted and screwed my installs.

Nick Østergaard (nickoe) wrote :

Did you make a backup of the files before deleting them? It would be interesting to see if there was something unexpected.

Changed in kicad:
status: New → Incomplete

Yes, here they are

You have some files located in network shares in your recently used paths. Did they change/become unavailable?

No, they didnt, i still have acess to all of them

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments