KiCad blocked in an infinite loop when using "/" in a footprint name

Bug #1825300 reported by KiCad bug report on 2019-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
Unassigned

Bug Description

When creating a new footprint in the footprint editor, I copied the component name from the supplier's data sheet into the value-field of the grid in the footprint properties (see also attached screenshot). This value contained a forward-slash "/".
Next a warning dialog popped up telling me that some specific characters should not be used.
When clicking on the "ok"-button of this warning-dialog, the dialog closes, and immediately pops up again with the same message. The only solution to get out of this infinite loop, was to force-quit the KiCad process on OS-level (resulting in the loss of all unsaved work).

Application: kicad
Version: (5.1.0-0), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.54.0 LibreSSL/2.0.20 zlib/1.2.11 nghttp2/1.24.0
Platform: Mac OS X (Darwin 17.7.0 x86_64), 64 bit, Little endian, wxMac
Build Info:
    wxWidgets: 3.0.4 (UTF-8,STL containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.51.0
    Compiler: Clang 8.0.0 with C++ ABI 1002
Build settings:
    USE_WX_GRAPHICS_CONTEXT=ON
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Changed in kicad:
milestone: none → 5.1.2
Jeff Young (jeyjey) wrote :

@Nick, do you have a 5.1.1 build? I can't reproduce this in 6.0, and I suspect it might already be fixed in 5.1.1 too.

Nick Østergaard (nickoe) wrote :

Mm, I did not test this but just saw it was a 5.0 build.

Can the OP or someone please test it on 5.1.1 as proposed by Jeff

Changed in kicad:
status: New → Incomplete
Wayne Stambaugh (stambaughw) wrote :

I tested it on 5.1.1 downloaded from the KiCad website on windows and I didn't have any issues. It appears that this has already been fixed or it was not the / character that caused the issue. I copied foo/bar from a text editor into the new footprint name dialog.

Hi, just for completeness, I had the issue with version 5.1.0-0 (release build) on Mac OS X.
As "special characters" (non alpha-num) I had forward-slash "/", dot ".", dash "-" and space " " in the name which caused the problem.

Next, I re-tried, and noticed that the issue only appears when you enter this kind of faulty name directly in the grid. When entering the same name in the input-field below in the dialog, I did not end up in the infinite loop.

Jeff Young (jeyjey) wrote :

Thanks for the follow-up. That one is definitely fixed in 5.1.1.

Changed in kicad:
status: Incomplete → Fix Committed
importance: Undecided → High
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers