Comment 15 for bug 1825170

Jon Evans (craftyjon) wrote :

Docs server is giving me 504 error right now so here are basic build instructions

git clone https://git.launchpad.net/kicad
cd kicad
mkdir -p build/debug
cd build/debug
cmake -DCMAKE_BUILD_TYPE=Debug ../..
make
sudo make install

If you are missing dependencies, cmake will tell you.
On ubuntu one way to get the dependencies is to uncomment the "deb-src" line in the PPA file in /etc/apt/sources/list.d/js-reynaud<whatever> assuming you use the PPA, and then do:

apt update
apt build-dep kicad

(this will take a while and a fair amount of disk space because it installs all the dependencies not only for building kicad itself, but also building the documentation)

Feel free to email me if you get stuck, I can try to help