pcbnew printing function no longer works properly

Bug #1824418 reported by htpcman on 2019-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

When I print both the preview and actual printout has low resolution and jagged edges. Some pads seem displaced and text is barely legible. If I plot a PDF with the integrated plot function the PDF is clean and I can print it without major issues but there seems to be a scaling issue as the printout is slightly smaller than 1:1.

I noticed that KiCAD 5.1 uses the system PDF renderer for generating the preview and probably also for printing. In my case this was Xreader 1.6. I replaced this in my Linux Mint system by Okular and now although the renderer is the Okular one I get the same result as before. Again If I open a PDF generated by the plot function in Okular I can print it correctly with slight scaling errors.

I have several printers installed in my system and they all show the same behaviour.

Printing worked perfectly in KiCAD 4.0.2 which I was using before KiCAD5.1. Since I now have a broken output function I will be forced to go back to KiCAD4.x

I will be happy to help and test any fixes.

Version Info

Application: kicad
Version: 5.1.0-060a0da~80~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.15.0-47-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

htpcman (s-nouri) wrote :
tags: added: printing
Rene Poeschl (poeschlr) wrote :

You could also use the plot functionality for the time being as a workaround (plot to pdf and print that)

Jeff Young (jeyjey) wrote :

@devs, this is fixed in 5.1.1 isn't it?

Possible duplicate (if it is indeed the same bug) https://bugs.launchpad.net/kicad/+bug/1823144

This is fixed.

Jeff Young (jeyjey) on 2019-04-19
Changed in kicad:
status: New → Fix Committed
milestone: none → 5.1.2
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers