Footprint names doubled in tree view

Bug #1820391 reported by Piotr Gałka on 2019-03-16

This bug report will be marked for expiration in 6 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

See attached scrennshot - each footprint in library is doubled in tree view (and klicking one selects both).
I've got that yesterday just after installing KiCad 5.1 (Windows 7, 64bit). But later it disapeared.
Today I've tried to repeat it from begining but I didn't got that error. So I'm not able to describe how to get it.

Here is how I got it (as not repeatable it probably will not help a lot)
- unisntall KiCad
- delete kicad dir from C:\Users\Piotr\AppData\Roaming
- install KiCad (only English and Polish help left, and installed not in 'C:\Program Files' but in my C:\Programy dir.
- make new Tmp dir in my D:\Mm\KiCad dir
- copy pic-programmer dir from C:\Programy\KiCad\share\kicad\demos to make D:\Mm\KiCad\Tmp\pic-programmer dir
- run KiCad
- File/Open Project (by default I was in Polish lanquage) and select pic_programmer.pro at D:
- run Footprint Editor
- accept standard setting to copy default lib tab
- here it worked very slowly (reading footprints) and I got window with some errors (don't know which, today I wonted to write them, but I didn't got them)
- then I got the tree view with footprints doubled,
- I have change the language to English,
- probably (this one point I'm not sure) I closed all KiCad windows and reopened them (it is because I noticed some time ago that after changing language menu was changed and dialog boxes not - don't know if it is still but habit left)
- I got attached scrennshot,
- it was working that way in all libs,
- I asked at forum if others see the same and was asked if I have an empty project opened,
- I opened (File|New) empty project and error disapeared and I could't get it again.

I know - it looks being not enough to find it but as I write some simple programs sometimes I think
that the author of the part of software showing that tree can probably imagine what conditions could lead to such display and than he (or someone else) can imagine how those conditions could come.

One more (connotation with bug I reported some time ago)...
During that process I was not asked if I wont graphic accelerated, but later I run PcbNew and was asked - so I really don't know in what toolset I was.

===========================
Application: kicad
Version: (5.1.0)-1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Piotr Gałka (piotrgalka) wrote :
Wayne Stambaugh (stambaughw) wrote :

If you can manage to duplicate this bug, please list the exact steps. I cannot duplicate this.

Changed in kicad:
status: New → Incomplete
Piotr Gałka (piotrgalka) wrote :

I can't duplicate.
It was the first I sow after installing KiCad 5.1 (the first application I run was Footprint editor).
After changing the project to new one the bug disapeared and I could't get it back.
I supposed it is just after installing KiCad 5.1 on clear computer, but when I have done it next time I didn't got it.
I was installing second time at the same computer and in my opinion in the same situation and from the same file (before first installation I sow at KiCad forum someone writeing checksums for it so I have compared the checksum before first installation).
In my opinion it is connected with the window with few errors I sow first time opening Footprint editor, but after second installation (after uninstallation) I didn't got that window.
I had no time to try it once more. Since a month I am not working with KiCad. Only because I sow 5.1 released I have installed it, had a short look at it and get back to my other works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments