Pcbnew crashes when using + or - hotkeys for zoom

Bug #1818868 reported by BobZ18188 on 2019-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

I thought I reported this bug yesterday but cannot see it. I don't think it got into your system.

I have used ExpressPCB for many years. It uses + and - as zoom hotkeys, so I chose the same for KiCad. They work OK in Eeschema but never work and often cause a crash in Pcbnew. This crashes all of KiCad; not just Pcbnew. I have attached an image of the error message which I sometimes get.

Application: kicad
Version: (5.0.2)-1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

BobZ18188 (bobz18188) wrote :
Seth Hillbrand (sethh) wrote :

Works for me under Linux version below. @BobZ18188, can you test a 5.1 release candidate build from https://kicad-downloads.s3.cern.ch/index.html?prefix=windows/nightly/ ? Pick the most recent one.

Application: pcbnew
Version: (5.1.0-rc2-38-g4612175da2), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.64.0 OpenSSL/1.1.1a zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Platform: Linux 4.19.0-2-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.64.0
    Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Changed in kicad:
status: New → Incomplete
Download full text (3.1 KiB)

Thank you.

Now Downloading 2019-03-05T23:29:08.571Z 899.0 MB kicad-r12490.4612175da-x86_64.exe

I think this should be correct for Windows 10 64 with Intel Core I5?

Do I need to uninstall my previous before running this .exe?

Bob Zwicker
<email address hidden>

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Seth Hillbrand
Sent: Wednesday, March 06, 2019 9:05 AM
To: <email address hidden>
Subject: [Bug 1818868] Re: Pcbnew crashes when using + or - hotkeys for zoom

Works for me under Linux version below. @BobZ18188, can you test a 5.1
release candidate build from https://kicad-
downloads.s3.cern.ch/index.html?prefix=windows/nightly/ ? Pick the most
recent one.

Application: pcbnew
Version: (5.1.0-rc2-38-g4612175da2), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.64.0 OpenSSL/1.1.1a zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Platform: Linux 4.19.0-2-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.64.0
    Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

** Changed in: kicad
       Status: New => Incomplete

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1818868

Title:
  Pcbnew crashes when using + or - hotkeys for zoom

Status in KiCad:
  Incomplete

Bug description:
  I thought I reported this bug yesterday but cannot see it. I don't
  think it got into your system.

  I have used ExpressPCB for many years. It uses + and - as zoom
  hotkeys, so I chose the same for KiCad. They work OK in Eeschema but
  never work and often cause a crash in Pcbnew. This crashes all of
  KiCad; not just Pcbnew. I have attached an image of the error message
  which I sometimes get.

  Application: kicad
  Version: (5.0.2)-1, release build
  Libraries:
      wxWidgets 3.0.4
      libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
  Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
  Build Info:
      wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
      Boost: 1.68.0
      OpenCASCADE Community Edition: 6.9.1
      Curl: 7.61.1
      Compiler: GCC 8.2.0 with C++ ABI 1013

  Build settings:
      USE_WX_GRAPHICS_CONTEXT=OFF
      USE_WX_OVERLAY=OFF
      KICAD_SCRIPTING=ON
      KICAD_SCRIPTING_MODULES=ON
      KICAD_SCRIPTING_WXPYTHON=ON
      KICAD_SCRIPTING_ACTION_MENU=ON
      BUILD_GITHUB_PLUGIN=ON
      KICAD_USE_OCE=ON
      KICAD_USE_OCC=OFF
      KICAD_SPICE=ON

To manage notifications about this bug go to:
https://bugs.launchpad.net/kicad/+bug/1818868...

Read more...

Seth Hillbrand (sethh) wrote :

I would recommend uninstalling the previous version first.

BobZ18188 (bobz18188) wrote :

Sorry it appeared that my e-mail bounced and did not see another e-mail so just installed the new version. What happens now is that the +/- keys cause the software to switch copper layers. No crash. I see now that those keys are assigned to that function and in fact the hotkeys are now assigned to two functions. I do not know whether that was the case before I updated to the nightly. I think I would like to re-assign the layer switch hotkey but there are so many that choosing something uncommitted is not an obvious choice. Recommend an alternate set of hotkeys for switching layers?

BobZ18188 (bobz18188) wrote :

Using the present nightly build: If I try to re-assign up/down layer change to another hotkey which is allocated otherwise, I get a conflict message. I now have reset the hotkeys to KiCad default. If I try to re-assign zoom in/out (using this nightly) to +/- it simply ignores that request. When I did this with the stable build it allowed that change to +/- without informing me of any conflict. This is difficult for me to get a coherent understanding......

Application: kicad
Version: (5.1.0-rc2-38-g4612175da), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Seth Hillbrand (sethh) wrote :

Do you mean keypad +/-? Can you assign number-row +/- or is that also blocked?

Wayne Stambaugh (stambaughw) wrote :

You have to change the "Switch to Next Layer" and "Switch to Previous Layer" to a different key (I used Alt++ and Alt+-") then change "Zoom In" and "Zoom Out". Duplicate key definitions will ensure that one of the duplicate keys will not work correct.

I already tested this using 5.1.0-rc2-38-g4612175da) on windows and it works fine once you configure the hot keys correctly.

BobZ18188 (bobz18188) wrote :
Download full text (3.7 KiB)

Thank you, Wayne and Seth

First; the addresses from which I am receiving your e-mails starts with "bounces". Earlier I received a response indicating "Submit request failure" so it seemed like this communication method was not working, but I guess that it does work.

Second: I had no idea that the (+ and - on the numeric keypad) was any different from the (+ and - with the _ and = on the typewriter portion of the keyboard). However it seems to be different. In fact trying to reprogram the hotkeys using the numeric keypad symbols did not work. But using the main (alphameric) keyboard symbols it does work.

I needed to know what reasonable hotkeys were available in order to change layer up and layer down before I could change zoom in and zoom out. Hmmmm.. I was wondering but I see now that the asterisk seems to mean that I have customized it.

As I was working on responding to your messages, my laptop somehow got into typing Chinese and I had to get my wife's help (She is Chinese) to get it back.

But anyway; now that I am running the latest nightly build, and have made the changes you have suggested it seems to be working. It seems that I can use either either (keyboard or keypad) + or - keys in order to actually invoke the zoom command, even though those were not interchangeable for setting up the hotkeys.

Perhaps this is not a completely controlled experiment. I do not know exactly what I changed that fixed the problem. I am not eager to revert to the release build to reproduce the problem.

Bob Zwicker
<email address hidden>

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Wayne Stambaugh
Sent: Wednesday, March 06, 2019 10:58 AM
To: <email address hidden>
Subject: [Bug 1818868] Re: Pcbnew crashes when using + or - hotkeys for zoom

You have to change the "Switch to Next Layer" and "Switch to Previous
Layer" to a different key (I used Alt++ and Alt+-") then change "Zoom
In" and "Zoom Out". Duplicate key definitions will ensure that one of
the duplicate keys will not work correct.

I already tested this using 5.1.0-rc2-38-g4612175da) on windows and it
works fine once you configure the hot keys correctly.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1818868

Title:
  Pcbnew crashes when using + or - hotkeys for zoom

Status in KiCad:
  Incomplete

Bug description:
  I thought I reported this bug yesterday but cannot see it. I don't
  think it got into your system.

  I have used ExpressPCB for many years. It uses + and - as zoom
  hotkeys, so I chose the same for KiCad. They work OK in Eeschema but
  never work and often cause a crash in Pcbnew. This crashes all of
  KiCad; not just Pcbnew. I have attached an image of the error message
  which I sometimes get.

  Application: kicad
  Version: (5.0.2)-1, release build
  Libraries:
      wxWidgets 3.0.4
      libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
  Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
  Build Info:
      wxWidgets: 3.0.4 (wchar_t,wx c...

Read more...

Changed in kicad:
status: Incomplete → Fix Committed
milestone: none → 5.1.0
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments