Show tracks in outline mode, strange outlines

Bug #1816263 reported by eelik on 2019-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Seth Hillbrand

Bug Description

When I select "Show tracks in outline mode" pcbnew shows outlines as very thick. Screenshot attached. But they may change when I click on the board or zoom in/out. This is probably caused by the new GAL pixel alignment changes. Maybe those changes shouldn't be used in pcbnew at all because pcbnew has worked well without them?

Application: kicad
Version: (5.1.0-rc1-70-gd15876595), release build
Libraries:
    wxWidgets 3.0.4
Platform: Linux 4.15.0-45-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=OFF
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

eelik (eelik) wrote :
Seth Hillbrand (sethh) wrote :

Please include your anti-alias settings and toolset (Accelerated or Fallback)

eelik (eelik) wrote :

I'm just testing those... It seems to happen in both toolsets, but in a bit different way when antialiasing setting is changed. The original situation was Accelerated with 4x supersampling. Here's a screenshot with Accelerated and no antialiasing.

summary: - Show tracks in outline mode, thick outlines
+ Show tracks in outline mode, strange outlines
eelik (eelik) wrote :

In fallback antialiasing setting doesn't affect it. Here's a screenshot showing how it has changed with different zoom level. With some levels it's the same as in the first screenshot.

Not everything here seems to be predictable. Changing between settings may keep the outlines the same (buggy) even though it was looking different (buggy) before the changes.

KiCad Janitor (kicad-janitor) wrote :

Fixed in revision f1a60832e0c45d3276c151c5f46113177b0b2084
https://git.launchpad.net/kicad/patch/?id=f1a60832e0c45d3276c151c5f46113177b0b2084

Changed in kicad:
status: New → Fix Committed
assignee: nobody → Seth Hillbrand (sethh)
Seth Hillbrand (sethh) wrote :

I think that I hit all of the areas mentioned here but please re-open if you find something still amiss.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers