Crash when closing KiCad

Bug #1815743 reported by eelik on 2019-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

When I tried to close KiCad, yesterday's nightly build, it crashed. I was in a hurry and had to leave, so I don't remember exactly what I did. Probably just tried to close pcbnew window by using the window close button. I left it there and the project window, eeschema window and pcbnew window are still hanging.

I could open debugging with visual studio. Unfortunately it doesn't help much because nightly builds for Windows aren't built for debugging. Here's all I could get:

The thread 0x1f9c has exited with code 0 (0x0).
Unhandled exception at 0x0000148D96B00000 in kicad.exe: 0xC0000005: Access violation executing location 0x0000148D96B00000.

Call Stack:

> 0000148d96b00000() Unknown
  _pcbnew.kiface!00000000146a181e() Unknown
  _pcbnew.kiface!000000001440956b() Unknown
  _pcbnew.kiface!0000000014b12610() Unknown
  _pcbnew.kiface!00000000149cbfea() Unknown

Application: kicad
Version: (5.1.0-rc1-32-gf83927859), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Seth Hillbrand (sethh) wrote :

If anyone sees this, or there is a procedure to look at, please re-open.

Changed in kicad:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for KiCad because there has been no activity for 60 days.]

Changed in kicad:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers