Symbol editor segfaults on paste

Bug #1815525 reported by Jan Brittenson on 2019-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Critical
Jeff Young

Bug Description

Start KiCad
Click the Symbol Editor
New Library
Name and Save it
Add to Project
Select newly created library
Right click and Add Symbol
Create a new single unit symbol
Open an existing symbol, say Device:C_Small
Select all except ref and part (though you can select those too if you like)
Copy
Go back to the newly created symbol in the newly created library
Paste -> crash
(It may seem to work, just zoom out and wait a few seconds)

KiCad:

Application: kicad
Version: (5.1.0-rc1-9-g8f320697a), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.54.0 LibreSSL/2.6.4 zlib/1.2.11 nghttp2/1.24.1
Platform: Mac OS X (Darwin 18.2.0 x86_64), 64 bit, Little endian, wxMac
Build Info:
    wxWidgets: 3.0.4 (UTF-8,STL containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.54.0
    Compiler: Clang 9.0.0 with C++ ABI 1002
Build settings:
    USE_WX_GRAPHICS_CONTEXT=ON
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

OSX:

System Software Overview:

  System Version: macOS 10.14.3 (18D42)
  Kernel Version: Darwin 18.2.0
  Boot Volume: Macintosh HD
  Boot Mode: Normal
  Computer Name: zorkmid
  User Name: Jan Brittenson (bson)
  Secure Virtual Memory: Enabled
  System Integrity Protection: Enabled
  Time since boot: 6 days 5:11

Crash Reporter info attached.

Jan Brittenson (bson) wrote :
Wayne Stambaugh (stambaughw) wrote :

I cannot reproduce this on Linux so it's possible that this is macos specific.

Application: kicad
Version: (5.1.0-rc1-32-gf83927859), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 GnuTLS/3.6.4 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) nghttp2/1.32.1 librtmp/2.3
Platform: Linux 4.18.0-15-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Adam Wolf (adamwolf) on 2019-02-12
tags: added: osx
Jeff Young (jeyjey) on 2019-02-27
Changed in kicad:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 6.0.0-rc1
milestone: 6.0.0-rc1 → 5.1.0
Jeff Young (jeyjey) wrote :

This is a dereference of freed memory, so it's only serendipity that it doesn't crash on other platforms.

summary: - Symbol editor segfaults on paste on OSX
+ Symbol editor segfaults on paste
tags: removed: osx
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 22229fbba4022a722edb35f0b731f9a6d54032e3
https://git.launchpad.net/kicad/patch/?id=22229fbba4022a722edb35f0b731f9a6d54032e3

Changed in kicad:
status: Confirmed → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers