EEschema, menu, tools / edit symbol fields wrong column fill

Bug #1814380 reported by Michele Giorato on 2019-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
Seth Hillbrand

Bug Description

I encountered another problem with eeschema.
If you use "tools/edit symbol fields" the data inserted in a cell are written in the next one.
It 'a very dangerous thing especially for those like me, use the fields to indicate the code of the same component for different suppliers. At the moment I found digikey codes on the Farnell column.

Application: kicad
Version: 6.0.0-rc1-unknown-r14903-b6a06aa1, debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1a zlib/1.2.11 brotli/1.0.5 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.8.6/openssl/zlib nghttp2/1.34.0
Platform: Linux 4.20.5-200.fc29.x86_64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.66.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.1 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Did you originally author this schematic with another version? 4.0.7 definitely had this bug, but I don’t believe the current nightlies do. I’m not sure about 5.0.x.

Seth Hillbrand (sethh) on 2019-02-02
Changed in kicad:
assignee: nobody → Seth Hillbrand (sethh)
importance: Undecided → High
milestone: none → 5.1.0
status: New → Triaged
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 5c3f6f2abf07854559bae8861558f97f84bc7e6d
https://git.launchpad.net/kicad/patch/?id=5c3f6f2abf07854559bae8861558f97f84bc7e6d

Changed in kicad:
status: Triaged → Fix Committed
Michele Giorato (mr-miky64) wrote :

No, I did everything with 6.0rc, the only "anomalous" thing I imported a microscopic part of a 4.x scheme.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers