"Library Browser" -> "Choose Footprint" current symbol is not preserved

Bug #1813882 reported by Thomas Pointhuber on 2019-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

# Current Behaviour

When I view the current footprint in "Library Browser" and choose to use "Choose Footprint", I'm greeted with a collapsed tree which does not point at any footprint yet

# Expected Behaviour

show currently selected footprint when opening "Choose Footprint" if possible

# Version Information

Application: kicad
Version: (6.0.0-rc1-dev-1641-g872f0eb44), debug build
Libraries:
    wxWidgets 3.1.1
    libcurl/7.63.0 OpenSSL/1.1.1a zlib/1.2.11 libidn2/2.1.0 libpsl/0.20.2 (+libidn2/2.1.0) libssh2/1.8.0 nghttp2/1.35.1
Platform: Linux 4.20.4-arch1-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.1.1 (wchar_t,wx containers) GTK+ 3.24
    Boost: 1.69.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.63.0
    Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jeff Young (jeyjey) on 2019-01-30
Changed in kicad:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 5.1.0
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision b3319d29c184bfaed6233689a5a564516e769926
https://git.launchpad.net/kicad/patch/?id=b3319d29c184bfaed6233689a5a564516e769926

Changed in kicad:
status: Confirmed → Fix Committed
Thomas Pointhuber (pointhi) wrote :

@Jeff,

the same issue is present in eeschema with the "Symbol Library Browser".

The naming of those dialogs should be unified as well.

Jeff Young (jeyjey) wrote :

Good catch, Thomas.

Changed in kicad:
status: Fix Committed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision ca0164aa07661cfe760c4345ddb779a5a31f615c
https://git.launchpad.net/kicad/patch/?id=ca0164aa07661cfe760c4345ddb779a5a31f615c

Changed in kicad:
status: In Progress → Fix Committed
Thomas Pointhuber (pointhi) wrote :

@Jeff,

"Eeschema" -> "Place Symbol" -> "Choose Symbol" -> "Select with Browser" still does not work after this patch as expected.

Jeff Young (jeyjey) on 2019-01-30
Changed in kicad:
status: Fix Committed → Confirmed
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision f425f49c19360923c5d2f8b8a9650c8c2925c62c
https://git.launchpad.net/kicad/patch/?id=f425f49c19360923c5d2f8b8a9650c8c2925c62c

Changed in kicad:
status: In Progress → Fix Committed
Thomas Pointhuber (pointhi) wrote :

@Jeff,

the list goes on:

"Eeschema" -> existing symbol -> "Library Reference" shows same issue :P

"Eeschema" -> "Tools" -> "Edit Symbol library References..." should probably also point to the exising symbol instead of the last viewed symbol.

@Thomas, do you mean “Eeschema” -> existing symbol -> “Edit Properties” -> “Library Reference” for the first one? That works for me….

Second one in progress….

> On 30 Jan 2019, at 22:31, Thomas Pointhuber <email address hidden> wrote:
>
> @Jeff,
>
> the list goes on:
>
> "Eeschema" -> existing symbol -> "Library Reference" shows same issue :P
>
> "Eeschema" -> "Tools" -> "Edit Symbol library References..." should
> probably also point to the exising symbol instead of the last viewed
> symbol.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1813882
>
> Title:
> "Library Browser" -> "Choose Footprint" current symbol is not
> preserved
>
> Status in KiCad:
> Fix Committed
>
> Bug description:
> # Current Behaviour
>
> When I view the current footprint in "Library Browser" and choose to
> use "Choose Footprint", I'm greeted with a collapsed tree which does
> not point at any footprint yet
>
> # Expected Behaviour
>
> show currently selected footprint when opening "Choose Footprint" if
> possible
>
> # Version Information
>
> Application: kicad
> Version: (6.0.0-rc1-dev-1641-g872f0eb44), debug build
> Libraries:
> wxWidgets 3.1.1
> libcurl/7.63.0 OpenSSL/1.1.1a zlib/1.2.11 libidn2/2.1.0 libpsl/0.20.2 (+libidn2/2.1.0) libssh2/1.8.0 nghttp2/1.35.1
> Platform: Linux 4.20.4-arch1-1-ARCH x86_64, 64 bit, Little endian, wxGTK
> Build Info:
> wxWidgets: 3.1.1 (wchar_t,wx containers) GTK+ 3.24
> Boost: 1.69.0
> OpenCASCADE Community Edition: 6.9.1
> Curl: 7.63.0
> Compiler: Clang 7.0.1 with C++ ABI 1002
>
> Build settings:
> USE_WX_GRAPHICS_CONTEXT=OFF
> USE_WX_OVERLAY=OFF
> KICAD_SCRIPTING=ON
> KICAD_SCRIPTING_MODULES=ON
> KICAD_SCRIPTING_PYTHON3=ON
> KICAD_SCRIPTING_WXPYTHON=ON
> KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
> KICAD_SCRIPTING_ACTION_MENU=ON
> BUILD_GITHUB_PLUGIN=ON
> KICAD_USE_OCE=ON
> KICAD_USE_OCC=OFF
> KICAD_SPICE=ON
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1813882/+subscriptions

Thomas Pointhuber (pointhi) wrote :

@Jeff,

not on my system

# Version Information

Application: kicad
Version: (6.0.0-rc1-dev-1665-g55b5c7189), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.63.0 OpenSSL/1.1.1a zlib/1.2.11 libidn2/2.1.0 libpsl/0.20.2 (+libidn2/2.1.0) libssh2/1.8.0 nghttp2/1.35.1
Platform: Linux 4.20.5-arch1-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.69.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.63.0
    Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Thomas Pointhuber (pointhi) wrote :

similar issue when editing the footprint in the "Symbol Properties" using the alternative footprint chooser.

Jeff Young (jeyjey) wrote :

Huh. I can't reproduce that one either. Both show the active footprint for me.

@Devs, can anyone else reproduce this with current code?

Thomas Pointhuber (pointhi) wrote :

@jeyjey,

it seems to only reproduce on GTK3 with wx 3.0

Seth Hillbrand (sethh) wrote :

I can confirm this happens on Linux GTK3.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers