V6 dxf inport issue

Bug #1812840 reported by Sebastian Kulik on 2019-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
jean-pierre charras

Bug Description

Hi guys,

I found a issue in import of dxf-files.
In V5 all seems to be fine, in V6 nightly some of vectors are not correct (see my screenshot).
Any ideas?

Best regards,
Sebastian

Its actually the same dxf file.
My mechanical collegs exported from Inventor and I checked using Freecad and DraftSight- the file seems to be ok....

Nick Østergaard (nickoe) wrote :

Please provide test dxf file

tags: added: dxf import pcbnew
Nick Østergaard (nickoe) wrote :

And please be more specific about what versions you tested? What v5? What v6?

Oh, Im very sorry!
V5.0.2 (latest stable)
V6 r12192 (latest nightly)
Sysem: Win10x64
File: Ill add as attachment....;-)

Seth Hillbrand (sethh) on 2019-01-22
Changed in kicad:
importance: Undecided → High
milestone: none → 5.1.0
status: New → Triaged
Changed in kicad:
assignee: nobody → jean-pierre charras (jp-charras)
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision c56d6ad2dd5d3134b25cb46d4d02c3cdb3f269fe
https://git.launchpad.net/kicad/patch/?id=c56d6ad2dd5d3134b25cb46d4d02c3cdb3f269fe

Changed in kicad:
status: Triaged → Fix Committed

Confirmed. All works fine now..;-)

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers