Footprint editor stuck in imperial units mode

Bug #1811491 reported by Aaron Michael Williams on 2019-01-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

I was working on a footprint and switched the grid to imperial mode to get the 1.27mm grid I needed. After I did this, however, I am unable to switch back to metric. Each time I click on the mm button it immediately toggles back to in. When I saw this I abandoned the footprint I was working on and exited the footprint editor, not saving anything. When I re-opened the footprint editor the behavior was the same. I then restarted KiCad entirely and it still refuses to go into metric mode in the footprint editor. Furthermore, I now see the same behavior in the PCB editor. It too is now stuck in imperial mode.

I am running the latest version from OpenSUSE, 5.0.2.

Under .config/kicad/pcbnew I noticed that Units=1 and PcbFramePcbUserGrid_Unit=1
. I tried setting these to zero and it made no difference.

In the pcbnew editor I can get it to switch to mm, but it flickers back and forth a lot until it ends up there. As soon as I click on the footprint editor, however, it switches back to in and the footprint editor will not go into mm mode no matter what I do.

I restored a previous revision of the configuration that works. It looks like FpEditorUnits=0 causes the problem in .config/kicad/pcbnew.

Seth Hillbrand (sethh) wrote :

Seems to be fixed in latest code. Please reset if you can reproduce using a nightly build (kicad-unstable)

Changed in kicad:
milestone: none → 5.1.0
status: New → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers