Eeschema, Fallback shows only White window

Bug #1811066 reported by Thomas Pointhuber on 2019-01-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
Seth Hillbrand

Bug Description

On my system, Eeschema shows only a white window in "Fallback" Mode. Using "Accelerated" works fine.

PcbNew works in all 3 modes ("Legacy", "Accelerated", "Fallback") correctly.

I used the nightly build downloaded at 6.1.2019 from the website

# Version Information

Application: kicad
Version: (6.0.0-rc1-dev-1481-g5e705347b), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Wayne Stambaugh (stambaughw) wrote :

I cannot duplicate this. Anyone else on windows seeing this?

Changed in kicad:
status: New → Incomplete
Seth Hillbrand (sethh) wrote :

@Thomas- Can you look in preferences and check if this happens for all Fallback anti-alias settings?

Thomas Pointhuber (pointhi) wrote :

@sethh: changing anti-alais does not fix the bug.

Seth Hillbrand (sethh) wrote :

A few more annoying questions. Bear with me...

1) Does your cursor show in the window?
2) Do you see icons and menu buttons?
3) Do you see the status bar at the bottom and does it update when moving the mouse?
4) Can you take a screen shot of your Preferences->Eeschema->Colors dialog?
5) If you activate the "place component" tool, click and begin to place a new component, do you see the item before you place it? Do you see it after you place it?

Thomas Pointhuber (pointhi) wrote :

@sethh:

1) Cursor is visible
2) yes
3) yes
4) see attachment. Changing background color changes canvas color.
5) I see it in the choose Symbol viewer, but not the placed symbol

Thomas Pointhuber (pointhi) wrote :

Additional note:

I installed the current nightly with the bug still there. Nevertheless, I found out fallback works with a test project. The bug reproduces in my case on this project:

* https://github.com/GaudiLabs/OpenDrop/tree/master/OpenDropV3/Electronics/KiCad_Files

@Thomas
Your .sch file has an issue:
the bitmap scale is set to 0.0

See line 1132:
Scale 0.000000
and edit it to set the scale to 1.0
Scale 1.000000

It will fix your issue.

Wayne Stambaugh (stambaughw) wrote :

@JP, is it possible that Eeschema could actually allow a bitmap with a scale of 0? If so, we should fix that on read time. Also, why would a bitmap with 0 scale prevent all of the other objects from being shown on the fallback canvas?

@Wayne,
AFAIK, scale 0.0 is a old bug in a nightly, fixed since a long time, when saving a sch file with a bitmap.
It is currently not possible to set the scale to 0.0 in Eeschema.

However, I'll have a look into this issue later.
Currently, I am trying to fix a much more annoying bug.

Seth Hillbrand (sethh) wrote :

@jp, let me know if you don't have time to deal with this and I can probably address it.

Changed in kicad:
assignee: nobody → jean-pierre charras (jp-charras)
importance: Undecided → High
milestone: none → 5.1.0
status: Incomplete → Triaged

@Seth,
Please do.
Thanks.

KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 72c885797e6077afa62d7ff90aaeb3b87f8452fe
https://git.launchpad.net/kicad/patch/?id=72c885797e6077afa62d7ff90aaeb3b87f8452fe

Changed in kicad:
status: Triaged → Fix Committed
assignee: jean-pierre charras (jp-charras) → Seth Hillbrand (sethh)

Sometime ago I also run into this problem (in the pre gal eeschema). Eeschema worked fine but the pdf plot of the schematic triggered a bug in the pdf viever (evince) and it would not render the pdf and the window borders of the viewer became corrupted. Once I found that the issue was the 0.0 scale I tried to reproduce from eeschema and the frame editor but I couldn't. At that time I was using the stable packages provided by debian (4.0.6 and later 4.0.7).

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers