pcbnew: ratsnets still show after connect with trace

Bug #1811010 reported by NhatKhai on 2019-01-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
High
Seth Hillbrand

Bug Description

Very smooth version to work on routing. However, I think ratsnets have a bug. When I have completed route board. Then move a component, reroute it completely, but small short ratsnets still show within the component PAD. DRC check show no unrounted nets (0 Unrouted).

Application: kicad
Version: (6.0.0-rc1-dev-1455-g4b7ef22ec), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

NhatKhai (nhatkhai) wrote :

Well if I save, and restart pcbnew. The ratsnet gone as expected.

Jeff Young (jeyjey) wrote :

Yeah, this has been annoying me lately too. I thought my build might just be behind but I guess not....

Changed in kicad:
milestone: none → 5.1.0
importance: Undecided → Medium
status: New → Confirmed
importance: Medium → High
Seth Hillbrand (sethh) wrote :

This and the per-pad ratsnest regression are part and parcel, so I'll hammer these down together

Changed in kicad:
assignee: nobody → Seth Hillbrand (sethh)
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 994be43782f1182b65f899cd9f79ee7360c2fdb4
https://git.launchpad.net/kicad/patch/?id=994be43782f1182b65f899cd9f79ee7360c2fdb4

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers