macOS - Crash on activating 3d view

Bug #1810550 reported by John Pateman on 2019-01-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Critical
Unassigned

Bug Description

On opening the 3D view from either pcbnew or the footprint viewer, the whole application crashes. This was not the observed behaviour with either 5.0.1 or with a current nightly - both of which show the 3D view correctly. I have attached the stack trace.

iMac 27" 3.06 GHz Intel Core 2 Duo
12 GB 1067 MHz DDR3
ATI Radeon HD 4670 256 MB
macOS 10.13

Application: kicad
Version: (5.0.2-4-gb601aea34), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.54.0 LibreSSL/2.0.20 zlib/1.2.11 nghttp2/1.24.0
Platform: Mac OS X (Darwin 17.7.0 x86_64), 64 bit, Little endian, wxMac
Build Info:
    wxWidgets: 3.0.4 (UTF-8,STL containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.51.0
    Compiler: Clang 8.0.0 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=ON
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

John Pateman (gasman2016) wrote :
Nick Østergaard (nickoe) wrote :

Did you use the kicad-unified-5.0.2-10_14.dmg or kicad-unified-5.0.2.dmg build?

tags: added: macos
Changed in kicad:
importance: Undecided → Critical

I used the kicad-unified-5.0.2.dmg as I am on macOS 10.13 and have not yet upgraded to Mojave.

John Pateman

Sent from my iPhone

> On 4 Jan 2019, at 20:16, Nick Østergaard <email address hidden> wrote:
>
> kicad-unified-5.0.2.dmg

Seth Hillbrand (sethh) wrote :

@Adam- This looks like an issue loading the dynamic library. Is it possible that the installer has a different version of libtbb from the compiler?

Adam Wolf (adamwolf) wrote :

Possible. It's built in the same exact VM that is wiped after every build.
However, it does download some dependencies off the internet.

I will regenerate a test 5.0.2-1 against the chance there was something
weird with dependencies that day.

Sorry folks. There is a tremendous amount of engineering in the Mac
builds, and yet...

On Fri, Jan 4, 2019, 6:40 PM Seth Hillbrand <<email address hidden>
wrote:

> @Adam- This looks like an issue loading the dynamic library. Is it
> possible that the installer has a different version of libtbb from the
> compiler?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1810550
>
> Title:
> macOS - Crash on activating 3d view
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1810550/+subscriptions
>

Adam Wolf (adamwolf) wrote :

Sorry, the email sent a little early.

There are a lot of tests I have added as part of the pre-5 packaging effort
to make sure that all of the libraries linked are either OS libraries that
Apple says are OK to link against or else inside the bundle.

On Fri, Jan 4, 2019, 6:49 PM Adam Wolf <<email address hidden> wrote:

> Possible. It's built in the same exact VM that is wiped after every
> build. However, it does download some dependencies off the internet.
>
> I will regenerate a test 5.0.2-1 against the chance there was something
> weird with dependencies that day.
>
> Sorry folks. There is a tremendous amount of engineering in the Mac
> builds, and yet...
>
> On Fri, Jan 4, 2019, 6:40 PM Seth Hillbrand <<email address hidden>
> wrote:
>
>> @Adam- This looks like an issue loading the dynamic library. Is it
>> possible that the installer has a different version of libtbb from the
>> compiler?
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1810550
>>
>> Title:
>> macOS - Crash on activating 3d view
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/kicad/+bug/1810550/+subscriptions
>>
>

Tomasz Wlostowski (twlostow) wrote :

@adamwolf:

iMac 27" 3.06 GHz Intel Core 2 Duo

This is a pretty old CPU, what are the compilation flags for OCE/OCC on OSX? Maybe the SIGILL is caused by an instruction unsupported by the CPU somewhere on OCC/OCE DLLS?

John Pateman (gasman2016) wrote :

As stated, a recent nightly does not exhibit this behaviour so this bug report was for info rather than any expectation of a fix

John Pateman

Sent from my iPhone

> On 8 Feb 2019, at 14:58, Tomasz Wlostowski <email address hidden> wrote:
>
> @adamwolf:
>
> iMac 27" 3.06 GHz Intel Core 2 Duo
>
> This is a pretty old CPU, what are the compilation flags for OCE/OCC on
> OSX? Maybe the SIGILL is caused by an instruction unsupported by the CPU
> somewhere on OCC/OCE DLLS?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1810550
>
> Title:
> macOS - Crash on activating 3d view
>
> Status in KiCad:
> New
>
> Bug description:
> On opening the 3D view from either pcbnew or the footprint viewer, the
> whole application crashes. This was not the observed behaviour with
> either 5.0.1 or with a current nightly - both of which show the 3D
> view correctly. I have attached the stack trace.
>
> iMac 27" 3.06 GHz Intel Core 2 Duo
> 12 GB 1067 MHz DDR3
> ATI Radeon HD 4670 256 MB
> macOS 10.13
>
> Application: kicad
> Version: (5.0.2-4-gb601aea34), release build
> Libraries:
> wxWidgets 3.0.4
> libcurl/7.54.0 LibreSSL/2.0.20 zlib/1.2.11 nghttp2/1.24.0
> Platform: Mac OS X (Darwin 17.7.0 x86_64), 64 bit, Little endian, wxMac
> Build Info:
> wxWidgets: 3.0.4 (UTF-8,STL containers,compatible with 2.8)
> Boost: 1.68.0
> OpenCASCADE Community Edition: 6.9.1
> Curl: 7.51.0
> Compiler: Clang 8.0.0 with C++ ABI 1002
>
> Build settings:
> USE_WX_GRAPHICS_CONTEXT=ON
> USE_WX_OVERLAY=ON
> KICAD_SCRIPTING=ON
> KICAD_SCRIPTING_MODULES=ON
> KICAD_SCRIPTING_WXPYTHON=ON
> KICAD_SCRIPTING_ACTION_MENU=ON
> BUILD_GITHUB_PLUGIN=ON
> KICAD_USE_OCE=ON
> KICAD_USE_OCC=OFF
> KICAD_SPICE=ON
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1810550/+subscriptions

Adam Wolf (adamwolf) wrote :

This is related to other library loading issues with 5.0.2-4. I have
released a 5.0.2-5 and it's in testing. If someone who is affected by
these issues could test it, (it's in
http://downloads.kicad-pcb.org/osx/testing), I can move it out of testing
and put it in releases. John, thank you for your help so far and submitting
this bug, it helped me realize the issues were systemic and not just with a
particular window with that release. Let me know if you could try on
5.0.2-5.

Thanks!

On Fri, Feb 8, 2019, 9:05 AM Tomasz Wlostowski <<email address hidden>
wrote:

> @adamwolf:
>
> iMac 27" 3.06 GHz Intel Core 2 Duo
>
> This is a pretty old CPU, what are the compilation flags for OCE/OCC on
> OSX? Maybe the SIGILL is caused by an instruction unsupported by the CPU
> somewhere on OCC/OCE DLLS?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1810550
>
> Title:
> macOS - Crash on activating 3d view
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1810550/+subscriptions
>

Seth Hillbrand (sethh) wrote :

Setting this to committed as it doesn't appear in the current nightlies. I do not observe this behavior with 5.0.2-5*Mojave.

Changed in kicad:
status: New → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments