File dialog *.* wilcard matching is wrong for files without a dot

Bug #1810221 reported by eelik on 2019-01-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Seth Hillbrand

Bug Description

This happens at least in the first time sym-lib-table setup dialog for eeschema if I try to select a custom sym-lib-table. It opens the file selection dialog with wildcard *.*. The file sym-lib-table is filtered out, it doesn't show. If I copy the file to a different name with an ending, e.g. sym-lib-table.sym-lib-table, it works. This leads me to believe that files without dot are just filtered out. That's natural because *.* requires a dot, otherwise it doesn't match.

This may be platform specific, I use gtk3 ATM.

Application: kicad
Version: (6.0.0-rc1-dev-1455-g4b7ef22ec-dirty), release build
Libraries:
    wxWidgets 3.0.4
Platform: Linux 4.15.0-43-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=OFF
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Seth Hillbrand (sethh) wrote :

I think that this is fixed by 4b7ef22ec48616b865bc7cd2eb97ce4e8dc438b6

If not, please reset the status

Changed in kicad:
milestone: none → 5.1.0
status: New → Fix Committed
eelik (eelik) wrote :

No, it doesn't help. I tried also reverting that commit, it didn't affect the bug either.

To be sure I tried creating empty files while the dialog is open. It immediately shows a file with an extension but doesn't show a file without an extension. So it's not just that specific sym-lib-table file which has a problem.

Changed in kicad:
status: Fix Committed → New
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 02a1bf1de65863f6dfdd2f31f89567d284daa6af
https://git.launchpad.net/kicad/patch/?id=02a1bf1de65863f6dfdd2f31f89567d284daa6af

Changed in kicad:
status: New → Fix Committed
assignee: nobody → Seth Hillbrand (sethh)
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers