KiCad copies fp-lib-table from current directory

Bug #1810169 reported by Patrick Pelletier
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Triaged
Medium
Wayne Stambaugh

Bug Description

This was originally discussed on the forum: https://forum.kicad.info/t/kicad-5-copies-projects-fp-lib-table-to-global-fp-lib-table/14383

I installed KiCad 5.0.2 on Ubuntu 16.04 from the PPA according to: http://kicad-pcb.org/download/ubuntu/

I then cloned a KiCad project (which happens to have a local fp-lib-table) onto the machine, and ran "kicad &" from within the project directory.

The first time I ran CvPCB, KiCad pops up a dialog saying it either gave me the standard KiCad libraries or an empty fp-lib-table. However, it did not do either of these things. Instead, the ~/.config/kicad/fp-lib-table it created was identical to the project's local fp-lib-table.

This is unexpected, and undesirable, because I don't end up with any of the standard KiCad libraries in my global fp-lib-table. (And the libraries that do end up in the fp-lib-table won't be meaningful in any other project than the first one that I opened.)

I would prefer that KiCad always set up the global fp-lib-table with the standard libraries. And if there is more than one thing it might do, it should say which thing it actually did, rather than saying "I did either this or that" and then actually doing a third thing.

version information:

Application: kicad
Version: 5.0.2-bee76a0~70~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-141-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Seth Hillbrand (sethh)
Changed in kicad:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 5.1.0
Changed in kicad:
assignee: nobody → Wayne Stambaugh (stambaughw)
Revision history for this message
Maciej Suminski (orsonmmz) wrote :

(Replacing Janitor today)

Fixed in commit b13efdb0f27d4db5114b69916c7a3e8bcc750eaa
https://git.launchpad.net/kicad/commit/?id=b13efdb0f27d4db5114b69916c7a3e8bcc750eaa

Revision history for this message
Patrick Pelletier (ppelleti) wrote :

I experienced this bug again today, on KiCad version 5.1.11, so it does not appear to be fixed.

I'm not convinced that this is a duplicate of bug #1809769. That bug is about the fp-lib-table being copied from the first project you open. This bug is about the fp-lib-table being copied from the current directory.

(For example, I was in the directory ~/cad/MotorBit when I ran "kicad &". The first project I opened was ~/cad/Palette/Palette.pro. KiCad copied my global fp-lib-table from ~/cad/MotorBit/fp-lib-table, NOT from ~/cad/Palette/fp-lib-table.)

Application: KiCad
Version: 5.1.11-e4df9d881f~92~ubuntu20.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.13.0-7620-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.71.0
    OpenCASCADE Technology: 7.5.2
    Curl: 7.68.0
    Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=ON
    KICAD_SPICE=ON

Revision history for this message
Nick Østergaard (nickoe) wrote :

@Patrick, we moved to gitlab quite some time ago, please open a new bug ther and refer to if applicable.

https://gitlab.com/kicad/code/kicad/-/issues/657

Revision history for this message
Patrick Pelletier (ppelleti) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.