PCBNEW -> EESCHEMA Symbol highlight artifact

Bug #1809731 reported by Thomas Pointhuber on 2018-12-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

# Howto reproduce

1. Open eeschema and pcbnew
2. click onto F.Fab Text of an Footprint
  * see the highlighted text in eeschema
3. click onto Footprint iteself
  * see the highlighted schematic symbol in eeschema
4. click at empty board area in pcbnew
  * see the highlighted text in eeschema is still there

# Expected Behaviour

Don't keep the text highlighted

# System Information

Application: kicad
Version: (6.0.0-rc1-dev-1435-gf9adc70fd), debug build
Libraries:
    wxWidgets 3.1.1
    libcurl/7.63.0 OpenSSL/1.1.1a zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.35.1
Platform: Linux 4.19.12-arch1-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.1.1 (wchar_t,wx containers) GTK+ 3.24
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.62.0
    Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Thomas Pointhuber (pointhi) wrote :
Seth Hillbrand (sethh) wrote :

@Thomas- This appears to be fixed. I recall seeing a bunch of cross-probe fixes go in a while ago. Can you verify that it is fixed for you as well?

Changed in kicad:
milestone: none → 5.1.0
status: New → Fix Committed
Thomas Pointhuber (pointhi) wrote :

The specific bug I reported is fixed, but a different one seems to be still there:

the highlighting is cleared only when the mouse-in event on eeschema occurs.

Seth Hillbrand (sethh) wrote :

OK thanks. That second issue should be fixed now.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers