pcbNew, Footprint Editor and Gerber viewer crash on start

Bug #1809487 reported by dave master on 2018-12-21

This bug report will be marked for expiration in 25 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

Application: kicad
Version: (5.0.2)-1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Hardware:
    Lenovo ThinkPad L540
    Graphics Card: Intel HD Graphics 4600
    CPU: Intel Core i3-4100M 2.5 GHz

Steps to reproduce:
 - In pcbNew, open new (empty) or old design (from existing project)
 - The design is loaded (or the empty canvas, in case of a new design)
 - As soon as i move my mouse into the canvas, pcbNew hangs and the canvas becomes gray.

 - The Footprint Editor behaves the same

 - The Gerber viewer has the same behavior if run in Modern Toolset (Accelerated) Mode. The other two modes work as expected.

Jeff Young (jeyjey) wrote :

Does the issue happen if you run PCBNew in Legacy mode? If that works fine, I'd try updating your graphics card drivers.

dave master (dave-master.) wrote :

I updated to the newest Driver:

Intel® Graphics Driver for Windows 7*/8.1* [15.36]
Driver Version: 10.18.14.5057
Driver Date: 8/16/2018

-> Still same behavior

Switching to the legacy toolset works, also using the fallback mode seems to work.

I never tried to acualy switch in an other mode, because the application crashed as soon as the mouse pointer was inside the canvas. But it is possible to switch mode if one is carefull to not point the mouse to the canvas.

The mordern canvas was working under Pcbnew 4.0.6 I had installed bevore, althou it sometimes came up with some openGL (if I remember correkt) warnings. If I clicked ok everything continued without any appereant issues.

So this kind of fixes my issue (I assume my crappy laptop graphics card won't be supported anymore in the future?), but it would still be nice to not crash the app if the wrong canvas is used. (This would be one lost user if he encounters this behavior on the first start of the first install, I guess)

Thank you

Seth Hillbrand (sethh) wrote :

Hi Dave-

Unfortunately, we have seen a number of issues with the mobile intel graphics drivers under Windows. If the updated drivers do not resolve the issue, the recommended solution is to use the fallback mode. The drivers report higher capabilities than they actually provide and accessing the video memory causes this type of crash. We've looked for ways to fallback gracefully but we are at the mercy of the driver manufacturer here.

Seth Hillbrand (sethh) wrote :

One other thing to also try is to disable anti-alias settings in OpenGL. This may partially resolve the issue for you

Seth Hillbrand (sethh) on 2019-02-23
Changed in kicad:
status: New → Incomplete
dave master (dave-master.) wrote :

Hi everyone,
finally got the time to test your suggestions. Thank you very much for your help.
I installed the KiCAD 5.1 Release and I'm very happy with the outcome.

At first, appearently there was still the same problem but KiCAD automatically fell back in the old mode. So this is a great fix for my first problem. Well done.

Than I tried to change the anti-alias settings and i seams this fixes my problem entirely.

Thank you verry much for your great work.

If I would be picky, i'd say it would be even better to enrich the notification pop-up, before the switch to the fall-back, with a hint to try common ways to fix the problem (like disabling anti-alias). I dont knwo if this is possible from a technical point of view.

Anyway, thank you very much and keep up the great work. It realy is much appreciated

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers