Latest nightly build lost configuration

Bug #1809442 reported by eelik
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
Undecided
Unassigned

Bug Description

I just installed the latest nightly build on Windows. KiCad seems to have lost the old configuration, I had to start from scratch. It doesn't seem to use %APPDATA%\Roaming\kicad\ config files anymore (even though they are still there). When I installed one day older (19th Dec) nightly build it worked again fine, it found the old config.

The commit 24f9bfa13b542674 seems to have something related to config, could this have something to do with it?

Application: kicad
Version: (6.0.0-rc1-dev-1419-g1d230bbee), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Revision history for this message
jean-pierre charras (jp-charras) wrote :

Yes, I confirm:
Since commit 24f9bfa13b542674, the Kicad config is stored in registry base, and no longer on disk.
Something was lost by this commit.

Changed in kicad:
status: New → Confirmed
Revision history for this message
eelik (eelik) wrote :

This is fixed but marked as such for the duplicate https://bugs.launchpad.net/kicad/+bug/1810002.

Changed in kicad:
status: Confirmed → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers