Grid ID not in grid list

Bug #1807541 reported by eelik on 2018-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Jeff Young

Bug Description

I deleted the config directory and restarted KiCad from scratch. I opened an existing project. When opening eeschema for the first time I got this warning:

Grid ID 12298 not in grid list, falling back to grid size( 100, 100 ).

I can repeat this also by deleting the line with "SchematicFrame_LastGridSize" from eeschema config file. And also for the symbol editor when the line with "LibeditFrame_LastGridSize" is deleted. I think 50 should be the default size and of course there should be no warning.

Application: kicad
Version: (6.0.0-rc1-dev-1353-gdd9a00107), debug build
Libraries:
    wxWidgets 3.0.3
Platform: Linux 4.13.0-46-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.8.0
    Compiler: GCC 7.2.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=OFF
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Jeff Young (jeyjey) on 2018-12-09
Changed in kicad:
status: New → In Progress
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 5.1.0
Jeff Young (jeyjey) on 2018-12-09
Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers