Eeschema autopan does not work in Linux

Bug #1807234 reported by Seth Hillbrand on 2018-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Medium
Maciej Suminski

Bug Description

When placing a new component or moving an existing component, Eeschema does not detect the mouse hitting the edge of the canvas and does not pan the view.

This worked correctly in 5.0.

I've checked that the common tick-box "Pan while moving object" is checked and unchecking does not change behavior.

Panning works correctly in pcbnew.

Application: kicad
Version: (6.0.0-rc1-dev-1336-ge94752a6c), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.62.0 OpenSSL/1.1.1a zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.34.0 librtmp/2.3
Platform: Linux 4.18.0-3-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.62.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=OFF
    KICAD_SCRIPTING_MODULES=OFF
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Changed in kicad:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 5.1.0
Changed in kicad:
assignee: nobody → Maciej Suminski (orsonmmz)
status: Triaged → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 63d4afb3eef056968588eb96aafb5f418b6d8cc5
https://git.launchpad.net/kicad/patch/?id=63d4afb3eef056968588eb96aafb5f418b6d8cc5

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers