Symbol Fields editor incorrectly groups references

Bug #1806330 reported by Grant Miller on 2018-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

This is what it looks like:

Reference | Value | Qty
R1 - R4 | 1k | 3
  R1 | 1k | 1
  R2 | 1k | 1
  R4 | 1k | 1
R3 | 2k2 | 1

The correct grouping should be "R1, R2, R4"

To reproduce:
  1. Open attached file in Eeschema
  2. Click "Edit symbol fields"
  3. Ensure "Group symbols" is checked

---

Application: eeschema
Version: 5.0.2-bee76a0~70~ubuntu18.10.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) nghttp2/1.32.1 librtmp/2.3
Platform: Linux 4.18.0-11-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Grant Miller (grantm11235) wrote :
Jeff Young (jeyjey) wrote :

If you want them grouped by value then you need to check the checkbox on the Value row under Group By.

This allows you to group on different criteria. For instance, you could also check Footprint if you want to separate 1K 1/4watt resistors from 1K 3watt resistors.

Grant Miller (grantm11235) wrote :

The problem is that the group of 1k resistors is labeled "R1 - R4" which would imply that R3 is part of that group.

Jeff Young (jeyjey) wrote :

Hmm... I'm not seeing that. I've attached a screen shot of it on my machine. Could you attach a screen shot so I can try and figure out what's different?

Grant Miller (grantm11235) wrote :
Jeff Young (jeyjey) wrote :

Oops, my bad, I didn't notice that you were on 5.0.2.

@Wayne, I've cherry-picked 3 commits from 5.1 to fix this. Is there going to be a 5.0.3, or is it pointless to push this to master?

Wayne Stambaugh (stambaughw) wrote :

@Jeff, I'm hoping there wont be a 5.0.3. Once 5.0.2 is released, I plan on announcing a string freeze for 5.1 so it shouldn't be too long before 5.1 is release. I'm shooting for FOSDEM which is the first weekend in February. I don't see any need to cherry-pick this into the 5.0 branch.

Jeff Young (jeyjey) wrote :

Cool; I'll just mark it fixed in 5.1.

Changed in kicad:
milestone: none → 5.1.0
status: New → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers