import dxf on windows 10

Bug #1805613 reported by Vladimir Guzenko on 2018-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
jean-pierre charras

Bug Description

Application: kicad
Version: (5.0.1)-4, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

On my Home PC under Windows 10 x64
When i try import dxf file nothing happens.
I was trying to import many files.
From LibreCad saved as R12 format.
Also files plotted from kicad pcb - File - Plot..

On my Ubuntu laptop, with KiCad version: 5.0.1-33cea8e~68~ubuntu18.04.1, release build, all work fine.

Seth Hillbrand (sethh) wrote :

We're in the process of releasing 5.0.2. Could you test kicad-5.0.2_1-x86_64.exe and see if your issue is addressed?

 http://downloads.kicad-pcb.org/windows/testing/

Changed in kicad:
status: New → Incomplete
Vladimir Guzenko (orion92) wrote :

Similar behavior.

Also i try to import dxf after changing toolset to Legacy, and got an error message.

Nick Østergaard (nickoe) wrote :

Does it happen with all files? Please provide example file.

tags: added: import
Vladimir Guzenko (orion92) wrote :

I found out what the problem is.
Russian keywords in file path.
If directory of imported file "C:/work/folder 1/проект 1/file.dxf" import fails without any messages.
If directory of imported file "C:/work/folder 1/project 1/file.dxf" import done successfully.

KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 5b3202d8f38bde3f9eb6a08322f0aa5aeacfb876
https://git.launchpad.net/kicad/patch/?id=5b3202d8f38bde3f9eb6a08322f0aa5aeacfb876

Changed in kicad:
status: Incomplete → Fix Committed
assignee: nobody → jean-pierre charras (jp-charras)
Changed in kicad:
milestone: none → 5.1.0
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers