pcbnew segfault on launch

Bug #1805002 reported by DashieV3 on 2018-11-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

I've started working on a project and installed kicad 5.0 stable on ubuntu from the ppa, eeschema works, but when trying to launch pcbnew it spew errors and then segfault. (same if I specify a pcb file from a previous project)

I've also tried with kicad-nightly and it just segfault without errors popups.

From the basic stacktrace the error in 5.0 and nightly are the same:
0x00007fffea33dbb7 in wxStatusBarBase::CalculateAbsWidths(int) const () from /usr/lib/x86_64-linux-gnu/libwx_gtk3u_core-3.0.so.0

I've attached "errors" with the errors on CLI (seems the same as popups) and the "bt full" stacktrace in GDB.

I'm able to build kicad from source if needed.

Here are some versions of my OS and packages related:

Ubuntu cosmic 18.10.

Application: kicad
Version: 5.0.0+dfsg1-2, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) nghttp2/1.32.1 librtmp/2.3
Platform: Linux 4.18.0-11-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

ii kicad 5.0.0+dfsg1-2 amd64 Electronic schematic and PCB design software
ii kicad-demos 5.0.0+dfsg1-2 all Demo projects for kicad
ii kicad-footprints 5.0.0-1 all Footprint symbols for KiCad's Pcbnew
ii kicad-libraries 5.0.0+dfsg1-2 all Virtual package providing common used libraries by kicad
ii kicad-nightly 201811240935+106eaaa~84~ubuntu18.10.1 amd64 Electronic schematic and PCB design software
ii kicad-symbols 5.0.0-1 all Schematic symbols for KiCad's Eeschema
ii kicad-templates 5.0.0-1 all Project templates for KiCad
ii libgnuradio-wxgui3.7.13:amd64 3.7.13.4-1build1 amd64 gnuradio wxgui functions
ii libngspice-kicad 0.1-2~201810171217+2e5be8d~ubuntu18.10.1 amd64 Library (shared) for ngspice. Used by kicad
ii libwxbase3.0-0v5:amd64 3.0.4+dfsg-4 amd64 wxBase library (runtime) - non-GUI support classes of wxWidgets toolkit
ii libwxgtk3.0-0v5:amd64 3.0.4+dfsg-4 amd64 wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
ii libwxgtk3.0-gtk3-0v5:amd64 3.0.4+dfsg-4 amd64 wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 runtime)
ii python-wxgtk3.0 3.0.2.0+dfsg-8 amd64 Python interface to the wxWidgets Cross-platform C++ GUI toolkit
ii python-wxversion 3.0.2.0+dfsg-8 all API for selecting the wxPython version to use

DashieV3 (dashie) wrote :
tags: added: packaging ubuntu
Maciej Suminski (orsonmmz) wrote :

Hi Dashie,

Which PPA have you used? Reynaud's PPA [1] provide 5.0.1, could you try to update?

1. https://launchpad.net/~js-reynaud/+archive/ubuntu/kicad-5/+packages

DashieV3 (dashie) wrote :

Hi,

haa sorry, your comment remembered me I had removed the kicad-5 ppa before installing the nightly (I didn't saw first that the "new" nightly permits installing alongside the stable)

before mixing things and forgotting, I used the js-reynaud/kicad-dev-nightly and js-reynaud/kicad-5.

I reinstalled it and upgraded kicad stable packages, but unfortunatelly still the same issue.

Attached is the "new" stacktrace but it doesn't spew wx popups errors this time.

Seth Hillbrand (sethh) wrote :

Hi Dashie-

Please check that you do not have any plugins in you ~/.kicad_plugins directory.

If you do, you will need to move them out as the 5.0 series does not support wx scripting on Linux. We are working to fix that for v5.1

DashieV3 (dashie) wrote :

Hi sethh,

Yes I have two plugins in that dir, moving them out fixed the segfault !

Thanks for pointing this out.

I guess we can close this issue if it's ok ?

Seth Hillbrand (sethh) wrote :

Thanks for reporting back. Once we have v5.1 out, you will be able to use those again with 18.04+

Changed in kicad:
milestone: none → 5.1.0
status: New → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers